[SOLVED] Visual Studio Express Problem

Discussion and feedback on Construct 2

Post » Wed Aug 06, 2014 7:29 pm

I am not a fan of the new W8.1 UI but that aside, I develop on a laptop which has W7 installed and everything works as expected.
Today, I've exported a Windows Store project which I've opened on the W8 computer (running 8.1) and it failed to import.
So, I've loaded the construct project in the W8 computer thinking that if I save from there, it would be possible to import it into Visual Studio Express for desktop 2013.

The first thing I notice is that under W8, my apps look ugly!
The background flickers between black and white (should be solid white) and every time I click or tap the screen, it too flickers.

On top of all of that, VS2013 can not open my project file.
VS Solution explorer adds (incompatible) next to my app name and underneath,
The application is not installed.

This was supposed to be easy. :(

Anyone experiencing the same?
Last edited by vancouver on Wed Aug 06, 2014 11:16 pm, edited 1 time in total.
B
14
S
4
Posts: 190
Reputation: 1,735

Post » Wed Aug 06, 2014 7:49 pm

I have tried to open the app (which was created on W7 and works as expected) with C2 running on W8.1 and then export it again as a Windows Store app.
The project file is only 3kb. Is that normal??? seems small.

The popup error msg is:
Unsupported
This version of VS is unable to open the following projects. The project types may not be installed or this version of VS may not support them ....

Then I click on the OK button which opens a local web page.

The main error msg there is: The application which this project type is based on was not found.

Unfortunately, I don't know what that means?

My version of VS 2013 is: 12.0.30501.00 Update 2 with .NET Framework version 4.5.51641
B
14
S
4
Posts: 190
Reputation: 1,735

Post » Wed Aug 06, 2014 8:26 pm

OK, it's not my app.

I've made a new, very simple app, filled in some sample info and exported.

Same thing. Unsupported.

At this point, I think I might try and download the VS2013 90 day demo because I smell that ether VS2013 Express is no good or I don't have the right version.

I'll be back!

--------------------------

On second thought, that requires 6GIG oh HD space which is a lot for something that might not even work and can only be used for 90 days.

Which version do you guys use to prepare your apps for the Windows Store?
B
14
S
4
Posts: 190
Reputation: 1,735

Post » Wed Aug 06, 2014 9:01 pm

i use VS2013 express and im having none of those issues in fact i would say its probably one of the best export options ive had to deal with are you follow the tutorial on exporting to windows
B
42
S
17
G
2
Posts: 850
Reputation: 6,209

Post » Wed Aug 06, 2014 10:00 pm

@volkiller730
did you install any other SDK's or any plugins?

It is totally weird that I cant even load a simple demo app with one coloured sprite and no functionality to speak of.

Something is very wrong here. :(

I just made another dummy project with C2.
Filled in all the data and info text.
Added the W8 object (left it at default values)
and exported as a Windows Store 8.1 app.
Opened the destination folder, and clicked the .sln file.
Visual studio opens right away with the msg Unsupported!

I can't get past that point which is very disappointing because I am pressed for time.
B
14
S
4
Posts: 190
Reputation: 1,735

Post » Wed Aug 06, 2014 10:12 pm

the only plugin i have is spriter in C2 ... that really weird i would make sure your pc it uptodate and you have the latest sevice packs and such also has your first post is kind of confusing are you using visual studio on windows 7 or 8


it look like something is not right with your visual studio check for updates

if you upload you exported blank project that your trying that's not working ill run it and see if its visual studio or C2
B
42
S
17
G
2
Posts: 850
Reputation: 6,209

Post » Wed Aug 06, 2014 10:23 pm

Sorry about the first post. It IS confusing because I was disappointed that my app didn't work well on w8.

I am running VStudio on a new computer that has w8.1 as an operating system.

Right now, I am re-installign VS becasues I think it never installed right in the first place.
Originally, I did a web install.

Anyway, I am a Mac guy and have a very low opinion on anything Microsoft makes. Good thing we don't have to pay for VS.
B
14
S
4
Posts: 190
Reputation: 1,735

Post » Wed Aug 06, 2014 10:47 pm

im actually a part time computer tech so if reinstalling it doesn't work im happy to try and help you get it working
B
42
S
17
G
2
Posts: 850
Reputation: 6,209

Post » Wed Aug 06, 2014 11:15 pm

Thank you volkiller730
but re-installing fixed everything.

Actually, if someone reads this PLESE NOTE:

DO NOT install Visual Studio 2013 for Windows Desktop

I have no idea what that is or does and I was not able to use it.

Installing: Visual Studio 2013 for Windows (takes a while) will
end with a license install, log in to your MS account etc...

I am testing now and everything works ... I think :)
B
14
S
4
Posts: 190
Reputation: 1,735


Return to Construct 2 General

Who is online

Users browsing this forum: DavidCerdeira, zenox98 and 10 guests