[Solved]Autorunner template problem

Get help using Construct 2

Post » Sat Oct 12, 2013 1:24 pm

Hi,
Link to capx:I can't post a url because of low reputation.

I just modified autorunner template a bit,I added walking animation and jump animation.

I haven't changed a condition,I have only added 2 action to set 'walk' animation when 'Platform is on floor'.

And set 'jump' animation when any key pressed i.e simulation platform jump.

I am facing few bugs:
1.Player is getting moved left a bit at a time and after a some time it will move out of the screen.
2.Player does not always perform jump when key is pressed.
3.When player is at the edge of a block,when I press key it will move right and fall.

Thank you.
neectron2013-10-12 16:11:31
B
12
Posts: 7
Reputation: 493

Post » Sat Oct 12, 2013 3:14 pm

2.Bug doesn't occur when 'jump' animation is removed.
B
12
Posts: 7
Reputation: 493

Post » Sat Oct 12, 2013 3:46 pm

Check the collision polygons and origin points are consistent across all animations.

Or use another sprite for the platform behavior with the animations pinned on top:
https://www.scirra.com/tutorials/253/how-to-make-a-platform-game/page-4

(BTW you can still post a URL as text)
B
55
S
29
G
19
Posts: 1,520
Reputation: 25,650

Post » Sat Oct 12, 2013 3:51 pm

here is the link h t t p://sdrv.ms/19yoVjd
B
12
Posts: 7
Reputation: 493

Post » Sat Oct 12, 2013 3:55 pm

2.Was fixed when I set animation to Platform On Jump rather the Simulate Platform Pressing Jump
B
12
Posts: 7
Reputation: 493

Post » Sat Oct 12, 2013 4:03 pm

What @Ramones said:

your animationframes are not all the same size. If you put the origin of all frames to the bottom all issues are solved.

Even better would be to pin your animation to another sprite with the platform-behaviour.
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Sat Oct 12, 2013 4:10 pm

Thanks guys,pinned the player sprite to a box with behaviour,it is working.
B
12
Posts: 7
Reputation: 493


Return to How do I....?

Who is online

Users browsing this forum: blackhornet, evillair, mongoose665, rbailey83, Yahoo [Bot] and 64 guests