[SOLVED]Connecting the legs and torso properly

Get help using Construct 2

Post » Fri Feb 22, 2013 7:45 pm

Hey, my player character is build from 3 objects.
Player- just a square box with platform behavior.
Torso-This one changes alot(weapons,aiming)

So i currently have this:
On start of layout: Torso pin to Player.
                     Legs pin to Player.

That works though, the thing is the walk animation makes my character jump a little. In the first frame the player stand higher than the other 2. But when I use Pin behavior it doesnt work.
This is how he is meant to walk:

here is the url so you can see how he currently walks: https://googledrive.com/host/0B-5Zgs_yQiBiV1F4NjRORmVQSlE/index.html

Also when you jump and go walk left or right when you just landed the animation will get stuck in idle pose. I don't really why that happens.

Derqs2013-02-23 01:15:45
Posts: 120
Reputation: 1,266

Post » Fri Feb 22, 2013 7:56 pm

I have no idea how you're using the pin behavior, but that probably doesn't matter at all. Adjust the sprite's hotspot for individual frames.
Posts: 1,910
Reputation: 13,155

Post » Fri Feb 22, 2013 9:35 pm

I just can't get it to work properly.

The two red dots indicate where these 2 object should connect.
So when those legs go 1px up, I want the torso to move 1px up too.
This doesn't really work with the Pin behavior I figured, because the sprites just stick to 1 point. Set position also does some strange things, so what would be a good way to connect those 2 dots?

EDIT: woa got it fixed finally, for anyone with the same problem:
I deleted the Playerobject and just gave the legs platform behavior.
I then used at every tick: Set position Torso to legs imagepoint1(I put where i had the red dot)Derqs2013-02-23 01:15:19
Posts: 120
Reputation: 1,266

Return to How do I....?

Who is online

Users browsing this forum: flemmig, g3nki, makkancs and 18 guests