[Solved]...Get sound on iPad when testing

Get help using Construct 2

Post » Wed Feb 05, 2014 7:36 pm

oh and then of course now that i go back to touchtest7 on iPad mini to try again.. it doesn't work now.. and now http://part12studios.com/temp/touchtest6/ works! wtf? this is insane.. I don't get how this could be so inconsistent and difficult to troubleshoot.
B
59
S
9
G
1
Posts: 939
Reputation: 6,545

Post » Fri Mar 14, 2014 2:28 am

Hi everyone, I just wanted to return back to this. I believe the issue I was having with audio wasn't C2 at all. It was the MIME settings on my web host service. m4a were not enabled. So if you ever have trouble getting audio to come through. Be sure your provider is configured to stream ogg and m4a.

This also helps with some Internet Explorer issues people may come across where they have no sound even on PC..

So after having fixed this issue, I went back and redid some tests.. http://part12studios.com/temp/SoundTest2/ works great now for both iPads.. I did however have to use preloading to insure they worked because when i didn't preload, audio didn't seem to fire off even after waiting awhile and even refreshing.. so seems that preloading is your best friend to insure audio is loaded and ready to fire off.

Thanks!
Caleb
B
59
S
9
G
1
Posts: 939
Reputation: 6,545

Post » Fri Mar 14, 2014 7:38 am

I'm glad you got it sorted - but I did ask about the mime setting in my second post...

Not got ipad available at the moment to test - there is something about music(?) not playing until a touch has been registered I read about but can't check at the moment ?
August 2015 - I misplaced a lot of links - I will try to find backups and repost. If You find a post that interests please reply to post with @rampackwobble and I will get a nudge!

If you find my posts useful please consider donating something to a local charity or to the http://www.mndassociation.org/
B
64
S
33
G
47
Posts: 1,194
Reputation: 30,832

Post » Fri Mar 14, 2014 1:56 pm

yea i see that now. I wasn't familiar with MIME.. that it was something that required action on my part.

yea that is true about the touch to hear sound, but that's usually addressed by having some kind of "touch to continue" prompt which feels natural to the user and achieves the need for touch.

I was just testing on my Galaxy S4 and it seems like sound is terribly delayed, not sure why that is, but i can't imagine its anything C2 has control over.. its so slow it's almost like the preloading is occurring with each touch.. but that's for another day i guess.. :)

Thanks!
Caleb
B
59
S
9
G
1
Posts: 939
Reputation: 6,545

Previous

Return to How do I....?

Who is online

Users browsing this forum: newt and 6 guests