[SOLVED]ParseSe (FrostyElk) Intel XDK Cardova build error

Get help using Construct 2

Post » Tue Sep 29, 2015 2:41 pm

Hi guys,

I'm trying to build my app in intel xdk with Cardova Crosswalk but I get an error when building. It seems that the ParseSe plugin from FrostyElk is the problem or am I seeing this wrong (pasted the error underneath)? Anyone got the same problem with the plugin?

Daan



:compileReleaseJava.../SweepyTest11/platforms/android/src/se/frostyelk/cordova/parse/plugin/ParsePlugin.java:99: error: cannot find symbol
webView.post(new Runnable() {
^
symbol: method post(<anonymous Runnable>)
location: variable webView of type CordovaWebView
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
1 error
FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':compileReleaseJava'.
> Compilation failed; see the compiler error output for details.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 28.581 secs

.../SweepyTest11/platforms/android/cordova/node_modules/q/q.js:126
throw e;
^
Error code 1 for command: .../SweepyTest11/platforms/android/gradlew with args: cdvBuildRelease,-b,.../SweepyTest11/platforms/android/build.gradle,-Dorg.gradle.daemon=true
Command finished with error code 8: .../SweepyTest11/platforms/android/cordova/build --release
ERROR building one of the platforms: Error: .../SweepyTest11/platforms/android/cordova/build: Command failed with exit code 8
You may not have the required environment or OS to build this project
Error: .../SweepyTest11/platforms/android/cordova/build: Command failed with exit code 8
at ChildProcess.whenDone (/Developer/cordova/5.1.1/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:134:23)
at ChildProcess.EventEmitter.emit (events.js:98:17)
at maybeClose (child_process.js:743:16)
at Process.ChildProcess._handle.onexit (child_process.js:810:5)
Last edited by ddaan9 on Mon Oct 05, 2015 8:14 am, edited 1 time in total.
B
7
S
2
G
1
Posts: 77
Reputation: 727

Post » Mon Oct 05, 2015 8:12 am

SOLVED!

Currently the plugin doesn't support the newest Cordova version. You should change your version to 4.X. You can do this at the main page with all your projects. Select a project and go to build settings. Change Cordova CLI Version to something that starts with a 4. For me it was 4.1.2.

This should do the tricks.

Thanks FrostyElk Devs, great product, great support!
B
7
S
2
G
1
Posts: 77
Reputation: 727

Post » Thu Oct 08, 2015 7:10 am

Cordova made some breaking changes when they released 5.0.

The automagic plugin handling will continue to support Cordova 4.x but if you need 5.x support for some other reason I have made a version only available at Github.

To use it you need to disable the current plugin and instead point the plugin URL to https://github.com/FrostyElk/cordova-parse-plugin

If you have any question please contact me at [email protected].
B
18
S
7
Posts: 88
Reputation: 1,424

Post » Sat Jun 25, 2016 1:41 pm

Arne wrote:Cordova made some breaking changes when they released 5.0.

The automagic plugin handling will continue to support Cordova 4.x but if you need 5.x support for some other reason I have made a version only available at Github.

To use it you need to disable the current plugin and instead point the plugin URL to https://github.com/FrostyElk/cordova-parse-plugin

If you have any question please contact me at [email protected].

is there a fix for this as intel xdk will not go less then 5.1 as of the last update. any help would be greatly appreciated. thanks again. Jeremy C.
B
29
S
13
G
10
Posts: 355
Reputation: 8,337


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 11 guests