[solved]Some texts are disorder with Sprite Font

Bugs will be moved here once resolved.

Post » Sat Jan 25, 2014 6:34 pm

edit : sorry! I found error

Link to .capx file (required! If link is blocked remove the http and www parts):
https://dl.dropboxusercontent.com/u/146680594/bugreport/aiuen.capx

Steps to reproduce:
1) use this tool (v2.2) to generate sprite font.
http://www.scirra.com/forum/sprite-font-generator-v2_topic72160.html

abcdefghijklmnopqrstuvwxyzABCDEFGHIJLKMNOPQRSTUVWXYZ??????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????



I did with this font (Kochi Mincho).
http://en.wikipedia.org/wiki/Kochi_font

2) load as instructed on C2, with the official plugin.

Observed result:


Expected result:
1) ?????, not ?????. (japanese)
2) Text ? must be displayed as is, not as ?.

Browsers affected:
Chrome: yes
Firefox: yes
Internet Explorer: yes
C2: yes

Operating system & service pack:
Windows 8.1, x64
see below

Construct 2 version: r158.2
Ch_Softblow2014-01-26 07:41:39
B
47
S
9
G
7
Posts: 75
Reputation: 7,586

Post » Sat Jan 25, 2014 10:41 pm

The image has a missing letter: line 5 after letter 12 it's missing "?" - or the character set is incorrect. Either way there's a mis-match. There might be other omissions but my Japanese is rather non-existent!
A big fan of JavaScript.
B
76
S
20
G
74
Posts: 2,253
Reputation: 46,480


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests