Sometimes Pathfinding Works, Sometimes Not

Get help using Construct 2

Post » Sun Oct 05, 2014 9:03 am

Hello,

I have objects have pathfinding, but sometimes they don't move, and after i close game and open it again, they start moving. (android)

on path found -> move along path

i also have this.

I don't think we need capx, because IT IS SOMETIMES WORKING, AND SOMETIMES NOT WORKING. that means they can move sometimes, so there would be nothing in the events. i wonder if it is a bug or sth of pathfinding/c2/crosswalk. (also sometimes happens when testing in the browser)

Anyone experienced this problem?
B
2
Posts: 3
Reputation: 156

Post » Mon Oct 06, 2014 8:55 am

up
B
2
Posts: 3
Reputation: 156

Post » Mon Oct 06, 2014 9:16 am

Sometimes could mean there are conflicting events sometimes..


So providing a capx would be the best idea..
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Tue Oct 07, 2014 9:49 am

Have you tried to regenerate the obstacle map at the beginning of the layout? I had to do this to make it work some time back. Not exactly sure why.
B
14
S
3
Posts: 123
Reputation: 1,571

Post » Tue Oct 07, 2014 5:32 pm

@oceldot this is a good idea. I have had a similar issue, will try that as well.
B
13
S
5
G
1
Posts: 119
Reputation: 2,292

Post » Tue Oct 07, 2014 5:39 pm

Yamachi wrote:Hello,

I have objects have pathfinding, but sometimes they don't move, and after i close game and open it again, they start moving. (android)

on path found -> move along path

i also have this.

I don't think we need capx, because IT IS SOMETIMES WORKING, AND SOMETIMES NOT WORKING. that means they can move sometimes, so there would be nothing in the events. i wonder if it is a bug or sth of pathfinding/c2/crosswalk. (also sometimes happens when testing in the browser)

Anyone experienced this problem?

Not saying it is, but your problem might be related to this one that I experienced. If there is something wrong with the path finding behaviour. Then it might explain why yours sometimes work and sometimes doesn't.
https://www.scirra.com/forum/path-finding-why-doesnt-this-work_t117025
B
44
S
11
G
2
Posts: 1,182
Reputation: 6,848

Post » Tue Oct 07, 2014 6:59 pm

Thanks for all replies, nowadays it has started working - i did nothing. Just after exporting a few times. But after launching the game 5-6 times, it happens again, and relaunch the game, problem disappears :/
B
2
Posts: 3
Reputation: 156


Return to How do I....?

Who is online

Users browsing this forum: AllanR, BackendFreak, farsen and 27 guests