sound in chrome

Bugs will be moved here once resolved.

Post » Wed Nov 16, 2011 2:59 pm

i having trouble with sound in chrome (its doesnt play smooth)

test

click to play sound

i have ogg and m4a in folders , is there a format i should add for chrome?

(in firefox its plays fine)

( EDIT I HAVE ADDED A SOUND AT START THATS LONGER)



vtrix2011-11-16 15:31:33
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Wed Nov 16, 2011 3:05 pm

it sounds the same to me in firefox, chrome, and opera O.o.
B
40
S
10
G
5
Posts: 102
Reputation: 6,602

Post » Wed Nov 16, 2011 3:22 pm

hu? so you dont hear the stutter (its like more echo and noise + it plays slower i think ) thx for trying..

that so strange, can somebody comfirm this?
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Wed Nov 16, 2011 3:42 pm

i must be doing something wrong because ive just tested other games and these sound good
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Wed Nov 16, 2011 3:49 pm

It sounds fine here, but in my testing I did come across something similar to what you describe - sometimes all the sound in Chrome is very stuttery, with lots of small gaps of silence. I think it's a bug in Chrome so we can't fix it ourselves, but I found usually just closing and reopening Chrome fixes it. Maybe they'll fix it in a future build.
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Wed Nov 16, 2011 4:04 pm

ow man this really is a pain for me right now, restarting doesn't work

+ i tried this construct2 game in the same browsersession, just replaced the url and it sounds good to me, so that makes me believe its some other problem, but the fact that you are all hearing good sound is really messing me up

http://dl.dropbox.com/u/22173473/PLANE%20CRAZY%20DROP%20BOX/index.html
(game by chrisbrobs)


i just tested the audioplayer by Kyatric, and the soundfx are stuttery and the music plays super! ow man...vtrix2011-11-16 16:20:33
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Thu Nov 17, 2011 8:06 pm

I just did a new test with a soundfile from another user,

i found out that its has the same weird stuttery sound if i import it to the soundmap,

but when i import it in musicfolder it plays perfectly!

i also tested my files directly into the browser and they play perfect, so i think there is still something wrong with the audioplugin in construct

im on vista64 maybe that has something to do with it?

ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Sun Nov 20, 2011 10:23 am

vtrix, I`m also on Vista 64 and am getting the same thing. Music seems fine but sound effects have a strange echo delay feeling to them. This only happens in Chrome and all of my drivers are up to date and working well.

I`m also getting a low framerate in Chrome compared to other browsers which seems strange. For example, Space Blaster runs at 53fps in Chrome but a solid 60 in IE and Firefox.
B
35
S
4
G
8
Posts: 65
Reputation: 6,106

Post » Sun Nov 20, 2011 12:16 pm

hi, thanx for replying so it has something to do with vista64 and (maybe vista in general?) in combination with chrome, will check this out further..

as for low framerate in chrome, last week chrome decided to disable the GPU Accelerated Canvas 2D at default, no idea why but they did, you have to manually enable it, put this in url   chrome://flags/

not sure why you getting good framerate in firefox tho, for me its really bad, especially physics, but i havent installed the construct webgl version, i rather wait a little vtrix2011-11-20 12:24:02
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Sun Nov 20, 2011 3:15 pm

Thanks for the tip, enabling GPU Accelerated Canvas boosted the frame rate but the sound still stutters. I wonder why this is disabled in the latest Chrome by default?

Regarding the sound, surely if this was a Vista problem (I know that there have been various sound problems with Vista in other programs)it would happen in all browsers?

Maybe it is just a Chrome bug as Ashley points out above.
Zeus2011-11-23 18:31:00
B
35
S
4
G
8
Posts: 65
Reputation: 6,106

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 8 guests