Sound not working on iOS 10

Bugs will be moved here once resolved.

Post » Mon Oct 03, 2016 12:59 pm

Problem Description

We recently tested our C2/Cordova project on an iPhone 6 (running iOS 9.3) and the sound worked perfectly. Today I upgraded to iOS 10.0.2 and the sound has now stopped working.

I can confirm this is only a problem with iOS 10, as we've also tested on an iPod (still running iOS 9.3) and the sound continues to work perfectly.

Attach a Capx
https://dl.dropboxusercontent.com/u/78057629/audiotestios.capx

Description of Capx
A simple capx that plays an audio track, on start of layout.

Steps to Reproduce Bug
  • Export app
  • Upload and build in PhoneGap
  • Run app on device using iOS 10

Observed Result
Audio does not work on device running iOS 10

Expected Result
Audio to work successfully, as with pre iOS 10 devices.

Affected Browsers
  • Chrome: (YES/NO)
  • FireFox: (YES/NO)
  • Internet Explorer: (YES/NO)

Operating System and Service Pack
Windows 10

Construct 2 Version ID
First tested on latest stable (r233) and then on latest beta (r236) in case problem had already been fixed.
B
33
S
6
G
7
Posts: 494
Reputation: 8,252

Post » Fri Oct 07, 2016 1:14 pm

Can't reproduce: ran it on an iPad Air 2 running iOS 10.0.2 and it worked fine.

You didn't describe your export options so I used WKWebView, btw.
Scirra Founder
B
397
S
236
G
88
Posts: 24,408
Reputation: 194,486

Post » Fri Oct 07, 2016 5:17 pm

Hi @Ashley, thanks for your reply.

However, we're still experiencing the issue.

In our first export (using r233) I did select the checkbox to use WKWebView. And if I remember correctly r236 is set up to use WKWebView automatically.

I also note that you tested the issue, using an iPad Air.

Whenever we've experienced iOS audio issues in the past (and as you know, there have been quite a few over the last few months) we've noticed that they almost always effect our iPhone 6. But the same issues haven't always caused problems on our other i-Devices (iPod & iPad Pro). Despite the fact that all device were running the same version of iOS at the time.

We have also had a report from one of our testers (also using iPhone 6 with iOS 10.0.2) and they've mentioned experiencing the same problem.

It could be worth testing this on an iPhone 6 (if you have access to one). Because we're still experiencing the issue, and we've run our tests using the same capx that we submitted to this bug report.

It's also worth pointing out that the capx we used does still play audio on our iPod & iPad (both of which are still on iOS 9.3).

Thanks for your time :)
B
33
S
6
G
7
Posts: 494
Reputation: 8,252

Post » Sun Oct 09, 2016 10:17 pm

I can also say that audio is not working on my iphone 5 (only device) with iOS 10, while it was fine with iOS 9

Regards Phil
B
9
S
1
Posts: 12
Reputation: 614

Post » Mon Oct 10, 2016 8:23 am

Hi @Ashley,

I know you've marked this bug as closed now, but we're still experiencing this problem. And so is one of our testers using the same iOS device and version. We're both using the same capx that you've tested, so we should be getting the same results, but we're not.

Would you be able to test on an iPhone 6 (running iOS 10.0.2) to see if you can reproduce the issue there?

Thanks for the help :)
B
33
S
6
G
7
Posts: 494
Reputation: 8,252

Post » Mon Oct 10, 2016 11:06 am

There's nothing much I can do if I can't reproduce the problem. Can you find a more reliable way to reproduce it, especially on an iPad Air 2? In exceptional circumstances we can purchase a device to investigate a bug report, but that is pretty expensive.
Scirra Founder
B
397
S
236
G
88
Posts: 24,408
Reputation: 194,486

Post » Mon Oct 10, 2016 12:15 pm

Hi @Ashley,

We appreciate that you don't want to purchase a new device, just to test a bug that doesn't seem to be affecting everyone. Perhaps you could test it on an older iPhone, to see if it can be reproduced there.

We know from our own experience (with iOS audio bugs) that not all i-Devices behave in the same way. When we experienced audio problems in iOS 9.2, that also seemed to affect iPhones but not iPads. So there is a precendent for this type of disparity between different iOS devices.

I've done some further research and I've found a similar audio bug, that was reported in connection with iOS 9.2. Here, on page 2 (https://www.scirra.com/forum/ios-sound-problems-since-ios-9-2_t167412?&hilit=audio+ios&start=10) you mention that you were unable to reproduce the bug on your iPad Air. And yet others continued to report the problem. Then on page 6 you mention that you were finally able to reproduce the issue on an iPhone 4S. Which seems to back up the idea that different i-Devices can react differently to bugs.

If there were some kind of major difference between our tests and yours (i.e. testing with a different capx) then perhaps it could be dismissed as an error on our part.

But when the only difference is the type of device we're both using, it would suggest that perhaps there is a problem, but (for some reason) it just doesn't show up on your iPad Air.

Thanks again for your time, we appreciate any further assistance you can offer.
B
33
S
6
G
7
Posts: 494
Reputation: 8,252

Post » Mon Oct 10, 2016 1:53 pm

Message: krejov100 can only post plain text URLS until they have 500 rep. 1 URLS modified. Why?
Hello @Ashley, I concur with blacksmith, it is know that the audio is different between devices.

I have also tried building and exporting the attached capx and there is no sound on my iphone 5

I appreciate that there is an expense associated with buying a device for testing, however the iPad air 2 makes up 3.5% of the apple device range while the iphone 5&6 cover more then 50% (http://hwstats.unity3d.com/mobile/device-ios.html). Can I suggest getting a second hand 5 to improve coverage (£100ish).

Is the iPad Air 2 the only device that you are able to test iOS builds on? Is there anything like logs or such that I could send you to help testing on iPhone 5.


Regards Philip
B
9
S
1
Posts: 12
Reputation: 614

Post » Thu Oct 27, 2016 1:28 am

i am having the same exact issue with an iphone 6, @ashley please buy a new test device, you have that ipad since years
Image

Image
B
38
S
14
G
7
Posts: 408
Reputation: 8,338

Post » Fri Oct 28, 2016 11:41 pm

Definitely iOS10+ has changed the way it handles audio with WKWebView.

I suspect older work-arounds to get music working on iOS9 (again because iOS9 changed the way it handles audio!! lol) are no longer compatible. :)
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 6 guests