Sound not working on offline web app

Get help using Construct 2

Post » Fri Mar 14, 2014 7:14 pm

Hi all
I have exported my game to dropbox and copied the public link of the index.html file. Using my IPad or Iphone I paste the public link address and I can play the game. I then 'Add To Homescreen' so that I can tap on the icon and play the game later without having to re enter public link address every time. This works fine , but I do not get the sound that's in the game. I did read somewhere about making sure the correct MIME types are set, but I have no idea where to look for these, or even if the correct MIME settings are sent when the game is loaded onto the device.
Can anyone shed any light on this, as to why I don't get the sound on the mobile device. The sound works fine on PC. I have uploaded game to Scirra Arcade and it works fine on there too.
Thanks
B
28
S
6
G
2
Posts: 86
Reputation: 3,267

Post » Fri Mar 14, 2014 7:38 pm

The MIME types would be set on your server:
https://www.scirra.com/manual/84/sounds-music

Just out of curiosity what was the original format of your sound? If it was the wrong type then Construct 2 didn't create the two types necessary:
https://www.scirra.com/manual/52/import-audio
B
17
S
4
G
3
Posts: 172
Reputation: 1,933

Post » Fri Mar 14, 2014 7:43 pm

@shirokuma
The original format was WAV, It has created the 2 files MP4 and ogg

Link :
https://dl.dropboxusercontent.com/u/151 ... index.html

do you have ipad or iphone maybe you could try. I don't have android device so not sure if it works on there.
B
28
S
6
G
2
Posts: 86
Reputation: 3,267

Post » Fri Mar 14, 2014 8:16 pm

I gave it a try on my iPad (1st Gen iOS 5.1.1) and there was no sound.

On my PC the only sound I heard was a crash sound when I died.
B
17
S
4
G
3
Posts: 172
Reputation: 1,933

Post » Fri Mar 14, 2014 8:28 pm

Should I export as HTML5 or open web app
B
28
S
6
G
2
Posts: 86
Reputation: 3,267

Post » Fri Mar 14, 2014 11:45 pm

@Gweely

Well, I don't think you did anything wrong. I just made a test project that is about as simple as you can make it, and the audio doesn't work on an iPad. I've served it up both with Dropbox and on my own web server. In both cases there was no audio on an iPad. This was a HTML5 export. I'm going to play around with it a little more.
B
17
S
4
G
3
Posts: 172
Reputation: 1,933

Post » Sat Mar 15, 2014 8:17 am

@Gweely

I was able to get it working on my web server, but not when it's served by Dropbox. All I did was on the start of the layout add a preload for the sound.
B
17
S
4
G
3
Posts: 172
Reputation: 1,933

Post » Sat Mar 15, 2014 11:29 am

I think I have got it working, I had to add MIME settings on my pc then upload to dropbox again and seems to be working
B
28
S
6
G
2
Posts: 86
Reputation: 3,267


Return to How do I....?

Who is online

Users browsing this forum: No registered users and 53 guests