sound playing with a very long delay on mobile

Get help using Construct 2

Post » Sun Sep 27, 2015 3:46 pm

hello!
i am working on a game. works fine on desktop and on some mobiles. - not on mine. i have an android 4.2.1
and there is a very long delay before i hear the sound. i tried it on ipad and at first it was fine and than it stopped working as well. for the sound i am using the sound object fade effects.

i exported my project to html5 .and also tried to make an apk. but i understand that as long as it doesnt work with Html there is no point.....the html folder is not very heavy only 3.25 mb

any ideas where i can start looking for a solution?
B
5
Posts: 18
Reputation: 261

Post » Sun Sep 27, 2015 4:25 pm

hmmm, is the sound set to preload before the layout runs?
B
65
S
38
G
24
Posts: 352
Reputation: 18,006

Post » Sun Sep 27, 2015 5:48 pm

oh, how do i do that? i am new to construct2../
B
5
Posts: 18
Reputation: 261

Post » Sun Sep 27, 2015 9:35 pm

Create event:
On start of layout
Add action (now find the audio file in the navigator that pops up)
Select preload

More info on preloading and audio can be found here:
https://www.scirra.com/manual/109/audio
B
65
S
38
G
24
Posts: 352
Reputation: 18,006

Post » Mon Sep 28, 2015 7:34 am

i think maybe it is something else because now i see that my preload sound was set to yes. and besides if i play the same sound again and again the sound still plays with delay...
B
5
Posts: 18
Reputation: 261


Return to How do I....?

Who is online

Users browsing this forum: R0J0hound, volumetv, Yahoo [Bot] and 15 guests