Sound Tag Issues

Discussion and feedback on Construct 2

Post » Thu Aug 28, 2014 7:18 am

For some reason, when I mute a Tag and play a sound, it will still play that sound. I am not sure if this is a bug or a design decision to only work with music.
Image
B
20
S
4
Posts: 105
Reputation: 2,315

Post » Thu Aug 28, 2014 1:39 pm

Did you play a sound with a sound tag, then mute this sound tag after a while, then play the same sound with same sound tag? Then, you have 2 instances of the same sound: one mute and one not mute.

Is this the case?
I got a game that you multiply, breath fire with two heads and brawl foes to oblivion with your clones: http://www.newgrounds.com/portal/view/660664 (use Chrome on Windows for best performance)

My sites:
http://twinblazar.deviantart.com
http://twinblazar.newgrounds.com
https://twitter.com/twinblazar
http://www.pixiv.net/member.php?id=15072448
B
30
S
11
G
11
Posts: 411
Reputation: 8,469

Post » Thu Aug 28, 2014 9:02 pm

Does it only mute the last instance? I want it to mute all instances with that tag. Right now, I just mute it with a sound button and want to unmute when it is clicked again.
Image
B
20
S
4
Posts: 105
Reputation: 2,315

Post » Thu Aug 28, 2014 10:57 pm

If that's your goal just have a variable controlling the sound:

If the variable is 1 and if any sound is playing - stop all sounds
If the variable is 0 and no sound is playing - play music

You could also save the playback time on must and seek to that value on unmute if needed.
B
33
S
12
G
7
Posts: 227
Reputation: 7,582

Post » Thu Aug 28, 2014 10:58 pm

I understand you can do that, but it should be a feature in the audio system but okay it is fine.
Image
B
20
S
4
Posts: 105
Reputation: 2,315


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 22 guests