SoundBug

Bugs will be moved here once resolved.

Post » Thu Mar 29, 2012 6:34 pm

I dont know if this has anything to do with chromes audio engine but wow, these effects bellow on this page are master to have in games.
http://chromium.googlecode.com/svn/trunk/samples/audio/index.html
B
56
S
20
G
13
Posts: 778
Reputation: 13,204

Post » Thu Mar 29, 2012 7:07 pm

@Savvy001, your .capx is insane! You're trying to play a new sound every tick, 60 times a second, and that's exactly what overloads and breaks the browser's audio engine. It only works in Chrome because it supports the Web Audio API which is a robust audio engine. You should try other browsers though, because it doesn't work at all in any browser other than Chrome.

All I can suggest is play one looping sound on start of layout and adjust that dynamically. This is not a C2 bug, you're giving the browser way too much audio to handle.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Post » Thu Mar 29, 2012 8:34 pm

Insane

Thats all a part of trying to accomplish something on your own without the knowledge how to do it.
And as the other web pages say on the internet: Chrome has problems with short audio files repeating fast.
I have tested the same thing with every (1.0) (0.5) (0.3) (0.1) and below (0.00) seconds playback with long and short audio files.
All have the same issue.
Not just this insane 0.0001 setup.

So thank u on this insight of having only 1 looping sample at start of layout.
I will try to get a good result with it.
Now i have learned more about the audio engine of chrome.
I can start over again and try to get it right.
And im happy that after all its not a C2 bug!Savvy0012012-03-29 20:34:56
B
56
S
20
G
13
Posts: 778
Reputation: 13,204

Post » Thu Mar 29, 2012 9:21 pm

That solved it!
I made a 15 sec synthesizer sound resembling a car engine on a constant pitch.
I set that to start looping on start of layout.
Re-set all the playrate settings in the capx and now it runs fine.
Still only chrome but thats no problem.

Thanx for the help on this! Savvy0012012-03-29 21:22:34
B
56
S
20
G
13
Posts: 778
Reputation: 13,204

Post » Fri Mar 30, 2012 12:59 am

Glad to hear it's sorted :)
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,528

Previous

Return to Closed bugs

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests