Sounds and music not playing on iOS

Bugs will be moved here once resolved.

Post » Thu Oct 27, 2016 1:39 am

Problem Description
Sounds and music not playing on iOS

Attach a Capx
private project


Steps to Reproduce Bug
  • create a capx with sound in it
  • export it to ios using phonegap
  • run app on ios device

Observed Result
the game doesnt play any sound or music

Expected Result
it should play music


Operating System and Service Pack
IOS 9

Construct 2 Version ID
C2 R239
Image

Image
B
38
S
14
G
7
Posts: 408
Reputation: 8,338

Post » Thu Oct 27, 2016 1:39 am

im going to publish a really big important update for my game and the sounds arent working...
Image

Image
B
38
S
14
G
7
Posts: 408
Reputation: 8,338

Post » Sat Oct 29, 2016 9:24 pm

Same problem here
Sound is not playing before you make action on screen
one of my games (HTML5 not mobile application ) on loader after load all content and images there a sound should play after complete the sound should enter the game , on web and android browser work 100 % , on ios browser you need to make call to action
B
14
S
2
Posts: 35
Reputation: 816

Post » Mon Oct 31, 2016 2:28 am

mnashwan wrote:Same problem here
Sound is not playing before you make action on screen
one of my games (HTML5 not mobile application ) on loader after load all content and images there a sound should play after complete the sound should enter the game , on web and android browser work 100 % , on ios browser you need to make call to action



so you finded a way to make it play music?
Image

Image
B
38
S
14
G
7
Posts: 408
Reputation: 8,338

Post » Mon Oct 31, 2016 8:58 am

you need to make any action like touch
so make a button to start
but this a tricky way to solve the problem
B
14
S
2
Posts: 35
Reputation: 816

Post » Mon Nov 14, 2016 5:11 pm

Closing, nothing we can do about reports like this, sorry. Please attach a .capx so we have something to investigate, as per the bug report guidelines.
Scirra Founder
B
395
S
233
G
88
Posts: 24,376
Reputation: 193,842

Post » Tue Nov 15, 2016 1:15 am

the problem was solved in other post, dont you remember ashley? i was having the same error as other user.
Image

Image
B
38
S
14
G
7
Posts: 408
Reputation: 8,338


Return to Closed bugs

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests