Sounds - problems with...

Discussion and feedback on Construct 2

Post » Tue Dec 20, 2011 9:28 pm

Friends, I have finished my application and now I'm doing a pretty simple game. But one thing I noticed was huge problems with sounds. Actually does not work very well. Summary:
In Chrome it gets echo, very eco
In Firefox works fine
Does not work on the iPad
Not yet tested in explorer.
What should I do to work on the iPad?
Obs. Im using the sound delivered with C2 that supposed to work...Vinians2011-12-20 21:31:55
Be nice with others and with yourself!
My musics: https://soundcloud.com/vinians
My C2 Forum:
http://nmbr.forumeiros.com/
My Site:
http://www.dicasebytes.com.br
B
21
S
5
G
6
Posts: 166
Reputation: 4,885

Post » Tue Dec 20, 2011 10:10 pm

@Vinians : it's not going to work like that. You check in the direction of the psot I made about Audiosprite for iOS platforms...
One of the problem is that you can't load/preload a song without user interaction, and you can't play a sound without loading it first. On top of that, you can't play simultaneously two sounds...
B
33
S
9
G
6
Posts: 709
Reputation: 6,704

Post » Tue Dec 20, 2011 10:37 pm

[QUOTE=Pode] @Vinians : it's not going to work like that. You check in the direction of the psot I made about Audiosprite for iOS platforms...
One of the problem is that you can't load/preload a song without user interaction, and you can't play a sound without loading it first. On top of that, you can't play simultaneously two sounds...[/QUOTE]

What ?? Here is the link of my app:
http://dl.dropbox.com/u/16702799/html5/EternalFly/index.html
As you can see its only 1 sound...
Z shot... or touch on the green button on IPAD.
Thanks
Be nice with others and with yourself!
My musics: https://soundcloud.com/vinians
My C2 Forum:
http://nmbr.forumeiros.com/
My Site:
http://www.dicasebytes.com.br
B
21
S
5
G
6
Posts: 166
Reputation: 4,885

Post » Wed Dec 21, 2011 12:04 am

New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,805

Post » Wed Dec 21, 2011 12:54 am

[QUOTE=Kyatric] A recap on current audio in HTML5[/QUOTE]
Yeah, I read this article and he tells us that the MPEG-4 AAC is supported by safari (browse the IPAD), then why is not working? When the C2 matter the sound it creates these formats, including a sound that I used own package comes in C2, this should not work?
Be nice with others and with yourself!
My musics: https://soundcloud.com/vinians
My C2 Forum:
http://nmbr.forumeiros.com/
My Site:
http://www.dicasebytes.com.br
B
21
S
5
G
6
Posts: 166
Reputation: 4,885

Post » Wed Dec 21, 2011 10:17 am

@Vinians: on iOS, the playing of an audio file, fom an HTML5 app, doesn't work like that. You need to preload the file when the user click on something, and then play it.
B
33
S
9
G
6
Posts: 709
Reputation: 6,704

Post » Wed Dec 21, 2011 12:53 pm

@Pode: Cool! I will try that, thanks a lot!
Be nice with others and with yourself!
My musics: https://soundcloud.com/vinians
My C2 Forum:
http://nmbr.forumeiros.com/
My Site:
http://www.dicasebytes.com.br
B
21
S
5
G
6
Posts: 166
Reputation: 4,885


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 5 guests