Spawning/Creating Object on animation event bug

Bugs will be moved here once resolved.

Post » Mon Sep 01, 2014 2:51 pm

Problem Description
If several sprites play the same animation at the same moment, and at frame X, they need to spawn/create 1 object, they spawn twice the number of objects instead of one each.

Attach a Capx

For Each [Character]
[Character] is playing animation "X"
[Character] is animation "3"
Tigger once

then Character spawn Object

It works fine if all [characters] do not play the same animation at the same time.
If they are synch, each character will spawn as many object there are characters


Steps to Reproduce Bug
  • Step 1 Create one character with one animation
  • Step 2 Spawn object at frame X
  • Step 3 Try to have several characters playing the same animation at the same time

Observed Result
____ What happens? ____

Expected Result
____ What do you expect to happen? ____ Each character should spawn one object

Affected Browsers
  • Chrome: (YES/NO) YES
  • FireFox: (YES/NO) YES
  • Internet Explorer: (YES/NO) YES

Operating System and Service Pack
____ Your operating system and service pack ____ windows 8

Construct 2 Version ID
____ Exact version ID of Construct 2 you're using ____ version release 178
B
26
S
10
G
3
Posts: 72
Reputation: 4,008

Post » Thu Sep 04, 2014 3:15 pm

Closing, please follow the bug report guidelines (attach a .capx)
Scirra Founder
B
397
S
236
G
88
Posts: 24,408
Reputation: 194,486


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests