Speed issue

For questions about using Classic.

Post » Sun Oct 09, 2011 11:07 pm

I was trying out some graphics in my learn-how-to-use-construct -project, and found that they cause a massive slowdown to my machine, when run. I fear this is due to several problems. One obvious reason would be that they are big and partially transparent, but my home made keyboard control may also do some damage.
I would like to be able to run it in fullscreen high res (1280x800 would look good) but that is just not possible at the moment.
Making the sprites non transparent with fewer colors or cutting them into several smaller ones did not seem to have any impact.

Any ideas about where to go from here?



http://dl.dropbox.com/u/42681740/check.cap

Check what 1280x800 does to it.
Thanks.
B
7
S
1
G
4
Posts: 31
Reputation: 2,241

Post » Sun Oct 09, 2011 11:25 pm

I'm too busy to check it, but you could try making a backup, then try deleting bits by bits until you find what was causing it.

Are you using lots of shader effects? Because those can slam the framerate hard.
Moderator
B
88
S
32
G
33
Posts: 3,005
Reputation: 27,432

Post » Sun Oct 09, 2011 11:52 pm

I only used semi-transparent sprites for shading, and replacing them with solid ones didn't really do anything. Thanks for the tip though.
It may run smoother or even flawless on a fast machine. Could someone verify that?
B
7
S
1
G
4
Posts: 31
Reputation: 2,241

Post » Mon Oct 10, 2011 7:03 am

Runs fine on my system - steady 60 FPS approx 125 MB VRAM, even the big room. But that is at 800x600 as I can't display the higher resolution.

Which makes me think why do you want to run it at such a high resolution? It would limit the audience IMO.

Quite nice looking up to now :)zenox982011-10-10 07:16:32
If your vision so exceeds your ability, then look to something closer.
Moderator
B
120
S
28
G
68
Posts: 4,850
Reputation: 48,301

Post » Mon Oct 10, 2011 3:25 pm

Thanks for looking at it.
Did you really not notice any difference in player turning speed, between the small and big rooms?

The problem with 800x600 is that the graphics are made for higher res, so everything will look big and blurry in fullscreen. Running in a window is really not an option since the idea was to have GUI bars with text and stuff (and they would turn out very small). Plus, the idea was also to have shooter sequences which demands a larger "view" for the player (i.e. you won't see the enemy until he is in your hair, running in 800x600).
Oh, well. I guess it's sprite scaling time then.
Thanks again.
B
7
S
1
G
4
Posts: 31
Reputation: 2,241

Post » Mon Oct 10, 2011 8:41 pm

Got it!
Turned out that it was the fullscreen function along with over use of always -events.
Fullscreen really seems to act in weird ways.
B
7
S
1
G
4
Posts: 31
Reputation: 2,241


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 3 guests