Speed testing

Discussion and feedback on Construct 2

Post » Wed Jan 18, 2012 3:17 pm

I've made simple game (800x600px, scrolling, moving with WASD).
It's here: http://tecbug.pl/pub/c2/speed/

I've encountered weird speed differences on old computers in browsers other than Chrome.

Please launch my game, move around and send here:
- FPS that you get while screen-scrolling (upper left corner)
- your system spec
- your browser (with a browsers version).

My laptop:
Intel Core2 T7200 @ 2.00GHz, 2GB RAM, NVIDIA Quadro FX 350M
Windows XP 32bit

Chrome 16.0.912.75: 59 FPS
Firefox 9.0.1: 11 FPS
Opera 11.60: 21 FPS
Maxthon v3.3.3.1000: 20 FPStecbug2012-01-18 15:18:08
B
53
S
14
G
10
Posts: 282
Reputation: 7,578

Post » Wed Jan 18, 2012 3:36 pm

It would really be helpful, if you would display the FPS on a HUD
B
42
S
19
G
12
Posts: 723
Reputation: 13,911

Post » Wed Jan 18, 2012 3:37 pm

PC:
Intel Core2 Duo E7500 @ 2.93GHz, 4GB RAM, Nvidia GForce 9500GT
Windows 7 32-bit

Chrome 16.0.912.75: 59~60
Firefox 6.0.2: 58~60
Firefox 9.0.1: 57~627Soul2012-01-18 15:51:36
B
83
S
21
G
15
Posts: 1,039
Reputation: 15,134

Post » Wed Jan 18, 2012 5:29 pm

Performance depends pretty much solely on whether the browser is hardware-accelerating the rendering. Old graphics cards might not be supported so you should say what the graphics card is on your different test machines. It's not a graphically intense game so I'd expect anything with a modern graphics card to get a solid 60fps. Also you should make sure you have the latest graphics card drivers since out of date drivers can cause slowness as well.

Also, do you have WebGL enabled? Where supported that can improve speed by 2-3x. You need to use the 'renderer' system expression to show which one is in use because WebGL may still not be supported and fall back to canvas 2d.

I get a solid 60 fps on Firefox 9, Chrome 16 and IE9 with latest drivers and a Radeon HD 6570.
Scirra Founder
B
359
S
214
G
72
Posts: 22,946
Reputation: 178,478

Post » Wed Jan 18, 2012 8:22 pm

[QUOTE=Weishaupt] It would really be helpful, if you would display the FPS on a HUD[/QUOTE]
Like I wrote "(upper left corner)". Hope You'll find it.
B
53
S
14
G
10
Posts: 282
Reputation: 7,578

Post » Wed Jan 18, 2012 8:37 pm

Windows 7

59-61 in FF 9.0.1 with a peak to around 65 when first bursting into the pyshic boxes.
60 in Chrome 16.0.912.75 m with a drop to around 40 when first busting into the physic boxes.

Also FPS are in black over a dark gray box, it can make it hard to see them at first.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 6,998
Reputation: 57,791

Post » Wed Jan 18, 2012 9:12 pm

Corrected FPS visibility (the same link). Hope it's better now.
I've also added "renderer" visible on the center of the level.tecbug2012-01-18 21:16:24
B
53
S
14
G
10
Posts: 282
Reputation: 7,578


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 10 guests