Sprite Distortion

For questions about using Classic.

Post » Thu Nov 12, 2009 7:20 am

What's up with this? Is this a bug or something?

The MM sprite looks fucked and distorted. I don't think it's a issue on my end.
B
11
S
3
G
8
Posts: 473
Reputation: 4,569

Post » Thu Nov 12, 2009 7:22 am

Nope its natural... Sprites tend to distort in Construct, I think this is because of being in decimal positions.

Try adding an Always event that sets the sprites position to round(sprite.x) & round(sprite.y) that might help.
B
2
S
2
G
3
Posts: 118
Reputation: 1,486

Post » Thu Nov 12, 2009 8:32 am

Sprite's position or sizes?

Anyway, I though it might be Construct's rendering engine.
B
11
S
3
G
8
Posts: 473
Reputation: 4,569

Post » Thu Nov 12, 2009 8:43 am

Try going from linear to point, shouldn't hurt anything considering your using pixelart anyways.
Image ImageImage
B
169
S
50
G
169
Posts: 8,285
Reputation: 108,214

Post » Thu Nov 12, 2009 9:09 am

I was in point.
B
11
S
3
G
8
Posts: 473
Reputation: 4,569

Post » Thu Nov 12, 2009 9:21 am

Ok.... um multisampling?
Or back to linear? :D
Image ImageImage
B
169
S
50
G
169
Posts: 8,285
Reputation: 108,214

Post » Thu Nov 12, 2009 10:39 am

What's it supposed to look like?
Scirra Founder
B
395
S
232
G
88
Posts: 24,368
Reputation: 193,756

Post » Thu Nov 12, 2009 11:23 am

I'm guessing something like this: (my edit on the left)





Yeah, all you need to do is - when your setting the position of that sprite to your detector that has the platform moevement, just round the coordinates. I think.
B
147
S
74
G
20
Posts: 1,786
Reputation: 22,527

Post » Thu Nov 12, 2009 11:40 am

Actually, like this:
Edit: crapped image...

But, I sort of don't get what you mean.
B
11
S
3
G
8
Posts: 473
Reputation: 4,569

Post » Thu Nov 12, 2009 11:51 am

Heres what I meant (I dont know if this is the solution, but it might work.)

http://dl.dropbox.com/u/1024727/meetmen.cap
B
147
S
74
G
20
Posts: 1,786
Reputation: 22,527

Next

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: R0J0hound and 0 guests