Sprite doesn't mirror

Get help using Construct 2

Post » Mon Jan 26, 2015 12:29 pm

I set up the events so that when the sprite collides with a tilemap, if it's not mirrored it gets mirrored and vice versa.
I've also tried to do it the way if it's overlapping at offset but it still doesn't work.

Does anyone have any idea how to solve this? I dunno how to fix this, although I am fairly sleep deprived so theres that.

Anyway, if anyone can tell me how I'm supposed to get this to mirror on collision/offset, so far I've got nadda.

How.png
You do not have the required permissions to view the files attached to this post.
The moderators are corrupt and ban for no reason, especially that condescending neckbeard asshole Kyatric. The forums are filled with fanboys.
Banned User
B
22
S
7
G
1
Posts: 558
Reputation: 2,925

Post » Mon Jan 26, 2015 12:47 pm

I believe we both are looking for the solution of the same problem.

In your case you can try to create global variable and change it's state first. And then apply "mirrored" action to your sprite in separate event.

Right now it change back to "not mirrored" state immediately after you change it to "Mirrored"
B
7
S
1
Posts: 7
Reputation: 436

Post » Mon Jan 26, 2015 2:39 pm

You may the condicion "ELSE"

here the image:
https://drive.google.com/file/d/0B9uHUU ... sp=sharing
B
48
S
9
G
10
Posts: 200
Reputation: 8,258

Post » Tue Jan 27, 2015 12:56 am

Thanks @luisgmolina that fixed it!
The moderators are corrupt and ban for no reason, especially that condescending neckbeard asshole Kyatric. The forums are filled with fanboys.
Banned User
B
22
S
7
G
1
Posts: 558
Reputation: 2,925


Return to How do I....?

Who is online

Users browsing this forum: David181 and 8 guests