Sprite Editor CTRL + Scroll Zoom Large Increment

All closed bug reports are moved here.

Post » Tue Apr 04, 2017 7:51 am

UPDATE: I won't move this to Github just because valuable information here is kinda hard to move.

In the Sprite editor, CTRL + Scroll using the mouse wheel should have low increment zooming in and out compared to the zooming in and out options available at the top Toolbar. This could have been a misplaced number hence a bug or could be just a feature request to ease the zooming function.

Observed result
Current Toolbar increment:
25 - 100 - 200 - 400 - 800 ... 6400

Current Mouse increment:
25 - 150 - 275 - 400 - 525 - 650 ... 6400

Expected result
At the initial increment should have been in smaller steps like 25 - 50 - 75 - 100 ... 6400. Perhaps a speed up with holding down shift.
Last edited by Jaydon on Thu Apr 06, 2017 5:50 pm, edited 2 times in total.
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Tue Apr 04, 2017 8:45 am

I can't reproduce this. My increments from CTRL + Mousewheel are the exact same as when I click on the Toolbar.
My addons:
[PLUGIN]Value Monitor
[PLUGIN] Text Alignement
[BEHAVIOR]Timescale Ratio
[BEHAVIOR]Polar Coordinates
[PLUGIN]Action Sequence
[BEHAVIOR]Action Sequence
[BEHAVIOR]Instance Variable Control
B
35
S
6
G
2
Posts: 229
Reputation: 3,390

Post » Tue Apr 04, 2017 8:54 am

skymen wrote:I can't reproduce this. My increments from CTRL + Mousewheel are the exact same as when I click on the Toolbar.


I tried to change the settings of the number of lines I scroll on my mouse through Window's settings but it doesn't affect it either.
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Tue Apr 04, 2017 12:39 pm

@Jaydon

I can't reproduce this one either. If you are in Windows the zoom progression for the mouse wheel and the toolbar buttons should be the same.

25% - 50% - 100% - 200% - 400% - 800% - 1600% - 3200% - 6400%.

Note: Initially the editor attempts to zoom the image to fit in the available space, so you might see zoom percentage numbers that don't fit in the scale. But as soon as you zoom in or out it finds the closest zoom level to fit in the scale.

Are you able to reproduce this consistently?
Scirra Employee
B
10
S
5
G
2
Posts: 132
Reputation: 2,356

Post » Tue Apr 04, 2017 12:48 pm

@DiegoM

I tried both on incognito mode and on regular browsing and the issue persisted. I made a gif file of me using the mouse wheel to zoom in and out with CTRL held down.

Here is a gif:
Image
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Tue Apr 04, 2017 5:38 pm

Can you post your platform information?

Go into the main MENU -> ABOUT -> Platform Information
Scirra Employee
B
10
S
5
G
2
Posts: 132
Reputation: 2,356

Post » Wed Apr 05, 2017 7:22 am

DiegoM wrote:Can you post your platform information?

Go into the main MENU -> ABOUT -> Platform Information


Here you go:

Code: Select all
Platform information
Browser: Chrome
Browser version: 57.0.2987.133
Browser engine: Blink
Browser architecture: 64-bit
Context: browser
Operating system: Windows
Operating system version: 10
Operating system architecture: 64-bit
Device type: desktop
Device pixel ratio: 1.25
Logical CPU cores: 8
User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

Local storage
Storage quota (approx): 2.7 gb
Storage usage (approx): 48 mb (1.8%)
Persistant storage: No

Browser support notes
This list contains missing features that are not required, but could improve performance or user experience if supported.

CSS element() is not supported.
Backdrop filters are not supported. Some UI effects are disabled.
WebGL information
Version string: WebGL 2.0 (OpenGL ES 3.0 Chromium)
Numeric version: 2
Supports NPOT textures: yes
Vendor: Google Inc.
Renderer: ANGLE (Intel(R) HD Graphics 4600 Direct3D11 vs_5_0 ps_5_0)
Major performance caveat: no
Maximum texture size: 16384
Point size range: 1 to 1024
Extensions:

EXT_color_buffer_float
EXT_disjoint_timer_query_webgl2
EXT_texture_filter_anisotropic
OES_texture_float_linear
WEBGL_compressed_texture_s3tc
WEBGL_debug_renderer_info
WEBGL_debug_shaders
WEBGL_lose_context
Audio information
System sample rate: 192000 Hz
Output channels: 2
Output interpretation: speakers
Supported decode formats:

Ogg Opus (audio/ogg; codecs=opus)
WebM Opus (audio/webm; codecs=opus)
Ogg Vorbis (audio/ogg; codecs=vorbis)
WebM Vorbis (audio/webm; codecs=vorbis)
MPEG-4 AAC (audio/mp4; codecs=mp4a.40.5)
MP3 (audio/mpeg)
FLAC (audio/flac)
PCM WAV (audio/wav; codecs=1)
Supported encode formats:

WebM Opus (audio/webm; codecs=opus)
Video information
Supported decode formats:

WebM VP9 (video/webm; codecs=vp9)
WebM VP8 (video/webm; codecs=vp8)
Ogg Theora (video/ogg; codecs=theora)
H.264 (video/mp4; codecs=avc1.42E01E)
Supported encode formats:

WebM VP9 (video/webm; codecs=vp9)
WebM VP8 (video/webm; codecs=vp8)
B
40
S
9
G
5
Posts: 177
Reputation: 6,805

Post » Fri Apr 07, 2017 1:33 pm

I also can't reproduce in r16, seems to work exactly as intended. Perhaps it's to do with your mouse scroll wheel settings?

Since nobody seems to be able to reproduce it, closing this issue - please file again via the new tracker if you find more details and want this followed up.
Scirra Founder
B
400
S
237
G
89
Posts: 24,550
Reputation: 195,527


Return to Closed Bugs

Who is online

Users browsing this forum: No registered users and 0 guests