Sprite Images getting distorted/Corrupted on Windows Phone

Discussion and feedback on Construct 2

Post » Mon Sep 01, 2014 3:48 pm

wp_ss_20140902_0003.jpg
wp_ss_20140901_0003.jpg


Problem Description
I am making a side scrolling game, where I am spawn Platforms above the Game layout. They gradually move downwards or to the left side. The game works perfectly on Windows 8.1 and the Construct 2 "Run Layout" in browser.
But when I port the same game to Windows Phone, the images are getting distorted/corrupted! This is not happening with all images.
I am using 256x160 sized tiles for Platforms and repeating 512x512 sprites for background/borders. Its the border images that causing the problem.

Attach a Capx
I would love to upload. But my company policies restrict me from doing so. :(
It has got many Artworks /sprites that we cant share yet.

However, here is a screenshot of the issue.
wp_ss_20140901_0003.jpg

Description of Capx
1. Spawn Platforms and background at regular interval.
2. These will scroll to the left and then get destroyed
3. I have a Player Sprite that performs standard platform moves (up down, left right)
4. Have coins/items appearing at random platforms which the player can collect

Steps to Reproduce Bug
    Only on Windows Phone. Appears immediately the game is started. Game works well on Computer browser and as a Windows 8.1 app.


Affected Browsers
  • Chrome: (NO)
  • FireFox: (NO)
  • Internet Explorer: (NO)

Operating System and Service Pack
Windows 8.1 Enterprise Edition x64 bit
Visual Studio 2013 Pro

Construct 2 Version ID
Construct 2 Beta release r177
You do not have the required permissions to view the files attached to this post.
Create your own Isometric Runner Game using C2:

Image

Check out my game "Last of the Survivors":
Play Store
App Store
B
60
S
14
G
2
Posts: 427
Reputation: 5,564

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 3 guests