Sprite jittering problem

For questions about using Classic.

Post » Wed Jun 29, 2011 3:54 pm

Greetings. My name is Kapus. I downloaded Construct yesterday hoping I could try my hand at a platformer. I just finished reading all of the "Platform School" lessons, and I'm ready to experiment with this engine.

So I started. Everything was going fine, but when I went to test, I ran into a problem. The Player character jitters around while jumping and walking. I figured this was a problem with the Collision Mask, but when I went to check it, everything seemed normal. I don't know what the problem is.

Here is the file. I'm hoping someone can help me with this.
http://www.sendspace.com/file/cbztdj


I..am very nervous asking about this. I don't know anything about this community and I am very new to Construct in general. I don't know if this is an obvious error or not. Either way, please help.
B
2
G
1
Posts: 3
Reputation: 456

Post » Wed Jun 29, 2011 4:06 pm

...Wierd. It doesn't happen on my computer. The player does... um... jitter a bit when turning around, for lack of a better word - ah, there it goes. I just had to tweak the animation frame size...

Do the player's animation frames have different dimensions (one's wider or shorter than the other, for example)?

PS Don't worry. This forum's pretty polite. No one's going to throw stones at you for asking a question.TheBen2011-06-29 16:07:51
B
8
S
2
G
6
Posts: 44
Reputation: 3,007

Post » Wed Jun 29, 2011 4:20 pm

[QUOTE=TheBen]
Do the player's animation frames have different dimensions (one's wider or shorter than the other, for example)?[/QUOTE]
No. The dimensions are the same in all frames. The Collision Mask is also the same size and in the same place in all frames.
B
2
G
1
Posts: 3
Reputation: 456

Post » Wed Jun 29, 2011 4:25 pm

I think the problem is hotspot.
Keep position of all hotspots of all frames of all animations at same coordinates.

Select hotspot tool, press "5" on numpad to place hotspot to center of frame, then hold Alt and click on hotspot to apply this hotspot's position to all frames in animation.
Repeat it for all animations
B
2
S
2
G
2
Posts: 158
Reputation: 1,366

Post » Wed Jun 29, 2011 4:41 pm

http://www.scirra.com/forum/topic43149_post269202.html#269202

Try this. I explain (in-depth) why sprite can jitter.
ImageImageImageImage
B
140
S
58
G
36
Posts: 2,547
Reputation: 31,170

Post » Wed Jun 29, 2011 7:17 pm

[QUOTE=DtrQ] I think the problem is hotspot.
Keep position of all hotspots of all frames of all animations at same coordinates.

Select hotspot tool, press "5" on numpad to place hotspot to center of frame, then hold Alt and click on hotspot to apply this hotspot's position to all frames in animation.
Repeat it for all animations[/QUOTE]
Thank you very much! The sprite jittering problem was indeed an issue with the Hotspot. I actually didn't know there was a Hotspot option.

Thanks again.
B
2
G
1
Posts: 3
Reputation: 456


Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 2 guests