Sprite scale r169

Bugs will be moved here once resolved.

Post » Mon May 12, 2014 12:56 pm

hop, try to export a node with downscaling "high quality", there is the bug !
B
9
S
2
Posts: 9
Reputation: 608

Post » Mon May 12, 2014 1:55 pm

I'm having the same thing with every pixel based project no matter what export type I try and no matter what the (new) downscale setting. If I have time tonight I'll provide a capx, but I have a feeling this will be an obvious fix as it's clearly only happening with sprite sheets.
B
46
S
9
G
2
Posts: 146
Reputation: 4,232

Post » Mon May 12, 2014 2:16 pm

For clarity I think the issue is this:
Exported HTML5 or Node-Webkit projects reduce the scale of animated sprites by 50%

However as I said, I did fix it. I believe I solved my issue by doing one of the following things:
  • Removing Touch Object
  • Removing WebGL Effects
I say that because those are the only things I changed before re-exporting and that seemed to solve it.
I'm at work now, but I'll try to recreate the bug in a simple .capx later.
B
15
S
5
Posts: 142
Reputation: 1,659

Post » Mon May 12, 2014 2:58 pm

The thing is, not everyone is seeing this unscale bug anata is referring to, which implies other factors must be involved.

I've tried the suggestion of changing the new 'Downscaling' option from the default of 'Medium' to 'High' and that does produce a strange offset bug, but not an unscaling bug.

With Downscaling set to 'High', the unscaled sprite is no longer at the same horizontal position as the scaled image. So something is definitely amiss there.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,558
Reputation: 60,460

Post » Mon May 12, 2014 3:04 pm

With the "Low Quality" or "Medium Quality" for Downscaling , all are good, but with a strange offset bug.

With the "High Quality" for Downscaling, animated sprite are 50% unscaled.
B
38
S
13
G
4
Posts: 152
Reputation: 5,147

Post » Mon May 12, 2014 3:57 pm

I don't think the .capx in the original post reproduces the problem, but I did notice a problem with the spritesheeting code in r169 which could have caused the oddly small sprite in the later screenshot. I think I've fixed it for the next build now.
Scirra Founder
B
403
S
238
G
89
Posts: 24,654
Reputation: 196,155

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 7 guests