SpriteFont: kerning way too off in some characters

Bugs will be moved here once resolved.

Post » Wed Jun 26, 2013 8:30 pm

Link to .capx file (required!):
same as this one:
http://www.scirra.com/forum/spritefont-space-is-too-big-the-gap_topic69924.html

Steps to reproduce:
type something

Observed result:

notice the kerning between "s" and other characters.

Expected result:
kerning is expected to be better.

Browsers affected:
Chrome: yes/no
Firefox: yes/no
Internet Explorer: yes/no

Operating system & service pack:
win7

Construct 2 version:
r136   
B
18
S
5
G
4
Posts: 568
Reputation: 5,079

Post » Wed Jun 26, 2013 8:36 pm

Pretty sure that's due to your charmap. There is an action to set the width of individual characters to fix this very problem. Looking at the .capx now..

Alright that might not be the case. However, each character is at the top left of its respected cel - maybe putting them in the middle will fix this?Tokinsom2013-06-26 20:40:09
Image
B
243
S
30
G
13
Posts: 1,787
Reputation: 18,770

Post » Wed Jun 26, 2013 8:47 pm

--California2013-06-26 20:51:26
B
18
S
5
G
4
Posts: 568
Reputation: 5,079

Post » Wed Jun 26, 2013 8:48 pm

[QUOTE=Tokinsom] maybe putting them in the middle will fix this?[/QUOTE] nope, already tried that, it stays the same.
B
18
S
5
G
4
Posts: 568
Reputation: 5,079

Post » Wed Jun 26, 2013 8:50 pm

[QUOTE=Tokinsom] There is an action to set the width of individual characters to fix this very problem./QUOTE] damn, you're right, that's way too buried, sadly doesn't work on the editor.
B
18
S
5
G
4
Posts: 568
Reputation: 5,079

Post » Thu Jun 27, 2013 1:14 pm

Closing, setting character "s" width to 25 on start of layout appears to fix this. It's up to you to use the correct artwork and 'set character width' action to get the letter spacing to what you want it to be.
Scirra Founder
B
399
S
236
G
89
Posts: 24,543
Reputation: 195,430


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest