spriter disappear when export to HTML5

Get help using Construct 2

Post » Sun Feb 23, 2014 9:44 am

lennaert,What about dropbox?
B
11
S
5
G
2
Posts: 496
Reputation: 2,306

Post » Sun Feb 23, 2014 10:07 am

I haven not tried spriter objects with dropbox.

But if dropbox does not show the scml files, and you cant change them in dropbox settings tosupport it with the needed mime types, then you will need to upload it somewhere else, somewhere where you can get the needed mime type support.
B
57
S
17
G
21
Posts: 1,878
Reputation: 19,562

Post » Wed Mar 26, 2014 12:15 pm

I added the MIME type with an .htaccess

AddType text/xml .scml
AddType text/xml .scon

And tried also to add the MIME type directly in Apache mime.types.

Both are working, because when done, Chrome displays this on top of page :
"This XML file does not appear to have any style information associated with it. The document tree is shown below."

I think it's fine if the .scml is recognized as a XML file.

However, my spriter animation is still broken (same : invisible sprites, dissassembled parts, no animation) after export on the host (but works fine in Construct 2)

Do you have an idea where it comes from ?
B
8
S
4
Posts: 131
Reputation: 1,205

Post » Wed Mar 26, 2014 1:53 pm

actually the MIME type was fine.

There was another issue : you have to uncheck "minify script" during export

Solved!
B
8
S
4
Posts: 131
Reputation: 1,205

Previous

Return to How do I....?

Who is online

Users browsing this forum: stevenode, tarek2 and 9 guests