Spriter/C2 update 11/2 bug fix for performance mode

Discussion and feedback on Construct 2

Post » Thu Dec 19, 2013 3:12 pm

Hi @lucid , I will build an webapp with some characters, animated with spriter, and I want to know what is better:
- create each character in a unique scml file
or
- create all the characters in a unique scml file, each one in an entity
B
90
S
5
G
8
Posts: 165
Reputation: 7,648

Post » Thu Dec 19, 2013 7:24 pm

@mostaafa You have to make sure your web server (IIS) has the mime/file types setup to allow .scon/.scml files...
B
49
S
11
G
10
Posts: 1,833
Reputation: 14,428

Post » Fri Dec 20, 2013 7:10 am

[QUOTE=Roccinio] any ETA for collision detection support in construct?
i want my player's sword on collision with an enemy to inflict damage.
i don't know how to pin an invisible sprite on the tip of the sword in an scml animation as a way to register collisions.
any ideas?[/QUOTE]

Have you thought about adding it to spriter in the animation, then once imported to C2, find the sprite in question and changing it's option to invisible. Just a thought, haven't tested it yet.
B
48
S
15
G
5
Posts: 183
Reputation: 8,476

Post » Sat Dec 21, 2013 1:42 pm

@MelVin
good idea! i turned collisions on for the sword png and it worked! happy day :)Roccinio2013-12-21 13:42:36
B
15
S
6
G
4
Posts: 277
Reputation: 3,948

Post » Sun Dec 22, 2013 4:49 am

Good stuff, happy to read it worked out Roc!:)
B
48
S
15
G
5
Posts: 183
Reputation: 8,476

Post » Fri Jan 03, 2014 7:35 am

Is there a way to make like this using spriter?

B
96
S
25
G
20
Posts: 3,055
Reputation: 22,644

Post » Fri Jan 03, 2014 4:28 pm

Interesting rigging; certainly possible but personally I'd find using bezier surface deformation more practical.

http://youtu.be/V0ehOfGP5XY?t=12m26s

Cannot wait for the plugin to be full featured; Spriter is performing incredibly well against the more expensive (And very similar) Spine.
B
49
S
14
G
3
Posts: 540
Reputation: 5,611

Post » Tue Jan 07, 2014 1:48 pm

@lucid - I still have the issue where my nodewebkit exports don't show the animations. I know they are there, as I have things spawning on their location, but they are not visible. And as someone else here exported the exact same capx and it works fine.

So, any ideas what could be going wrong? Is there some setting somewhere that might be causing this? It's been like this the last 3 betas and nothing I have tried seems to work.
B
27
S
8
G
5
Posts: 429
Reputation: 6,902

Post » Tue Jan 07, 2014 2:09 pm

[QUOTE=Tobye] @lucid - I still have the issue where my nodewebkit exports don't show the animations. I know they are there, as I have things spawning on their location, but they are not visible. And as someone else here exported the exact same capx and it works fine.

So, any ideas what could be going wrong? Is there some setting somewhere that might be causing this? It's been like this the last 3 betas and nothing I have tried seems to work.[/QUOTE]

@Tobye

Hi Tobye,

I had the same problem as you. My spriter animations worked in preview for chrome and node web-kid, but not when I exported.

For some reason the issue got resolved, when I put something into the "starting entity" and "starting animation". I dont know why exactly, because I only filled those fields for one of my characters, and even with a wrong starting entity, but suddenly my sprites where there when I exported.

I would suggest that you do the same. Just mess around abit, and export your project a few times.

Ah and dont tick minify script when you export ( at least I read that somewhere).

I hope that helpsAllchix2014-01-07 14:12:46
Free Android game: https://play.google.com/store/apps/deta ... VSMrMonkey

"Seven Birds VS Mr. Monkey" is a simple yet fun game.

Mr. Monkey is being attacked by birds and without a way to escape all hope seems lost. But if you think Mr. Monkey goes down that easily you are mistaken!

Help Mr. Monkey to upgrade his skills, get special attacks and show these birds who's the boss!
B
9
S
1
G
1
Posts: 51
Reputation: 755

Post » Tue Jan 07, 2014 4:01 pm

Thanks @Allchix, I finally got it working :D I don't know what it was exactly, I played around with lots of that stuff and added/deleted some spriter objects. I'd done it all in the past too. But, now it's working so I'm happy!
B
27
S
8
G
5
Posts: 429
Reputation: 6,902

PreviousNext

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 18 guests