Srange platform behaviour

Bugs will be moved here once resolved.

Post » Fri Oct 02, 2015 8:35 pm

Problem Description
Why does the player sprite dissapear if you jump up onto and stay on a platform whilst the triggers are being activated?

Attach a Capx
http://planetserve.com/game/test/test.capx

Description of Capx
Adds and removes 'platform' blocks when the rotating device triggers an event.

Steps to Reproduce Bug
  • Jump onto the first platform and then wait whilst the 'clock' cycles - the player sprite dissapears when the platform dissapears?

Observed Result
Jump onto the first platform and then wait whilst the 'clock' cycles - the player sprite dissapears when the platform dissapears?

Expected Result
I would expect the player to not dissapear but fall once the platform dissapears.

Affected Browsers
  • Chrome: (not tested)
  • FireFox: (YES)
  • Internet Explorer: (YES)

Operating System and Service Pack
Windows 7 64 Bit SP 1

Construct 2 Version ID
212.2 Stable
B
17
S
6
G
1
Posts: 83
Reputation: 1,895

Post » Fri Oct 02, 2015 8:46 pm

@planetserve

How is this a bug?

You are not creating and destroying the platform, but just moving them off screen, so if the player is on the platform, then he will be moved offscreen also.

Surely this is obvious. If you had a moving platform, would you expect the player to move with the platform or remain stationary? Same principle.

If you use System/Create to make the platforms appear, and then the sprite Destroy action, then the player will fall as expected.

see attached (r214) https://dl.dropboxusercontent.com/u/34306693/planetservetest.capx
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Mon Oct 12, 2015 3:51 pm

Closing, zenox98's description sounds correct (moving platform support means the player will move with any object they are standing on), and the provided .capx link now returns 404 not found and the file is mandatory for bug report investigation.
Scirra Founder
B
403
S
238
G
89
Posts: 24,654
Reputation: 196,145

Post » Wed Oct 14, 2015 7:38 pm

Hi Ashley, This was obviously not a bug so I deleted the file. Is that OK?
B
17
S
6
G
1
Posts: 83
Reputation: 1,895

Post » Thu Oct 15, 2015 9:23 am

planetserve wrote:Hi Ashley, This was obviously not a bug so I deleted the file. Is that OK?


Thanks for answering, but it would have been polite to let us know earlier to save Ashleys time.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,556
Reputation: 60,456

Post » Thu Oct 15, 2015 6:41 pm

Sorry, my heads all over the place at the minute. In the future, I will think twice about submitting anything until I have my facts right.
B
17
S
6
G
1
Posts: 83
Reputation: 1,895


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests