Starting music on CocoonJS/iOS?

Get help using Construct 2

Post » Wed Nov 13, 2013 12:33 pm

Hello all,

I know there have been a few issues reported about audio and music after exporting with CocoonJS in the past, but I don't recall anything like what's happening to me right now

Basically, once I built the project in XCode and run it on my device, even if I have an action to start playing a music file in the OnStart of layout event, the music in each layout doesn't play till I touch the screen (anywhere, without necessarily triggering another event).

Did anyone experience something like this? Did you manage to find a solution? Eventually, is there any way to "simulate" a touch event without actually having any so I can start the music?

I'm using the latest r150 (but the problem was already there in r149 the first time I tried exporting) and testing on an iPad 2 with iOS 6.1.

Thanks in advance for any ideas!    roberto2013-11-13 12:36:58
Image Image Image
B
82
S
21
G
8
Posts: 163
Reputation: 11,516

Post » Thu Nov 14, 2013 8:12 am

Can you provide us a .capx of this issue? That would be great for find a solution.
B
9
S
4
G
4
Posts: 383
Reputation: 3,616

Post » Thu Nov 14, 2013 9:01 am

@ludei we've also got the same issue. I can't reproduce though, which is frustrating. @roberto can you let me know if you can repro with a minimal .capx?

Just to confirm, the issue doesn't occur on Android, only on iOS, and I can't seem to repro with just a basic .capx.
Moderator
B
72
S
14
G
11
Posts: 900
Reputation: 11,940

Post » Mon Nov 18, 2013 2:26 am

Thanks for the replies. I'm trying to replicate with a minimal capx. If not, I'll send @ludei a link to download the full capx of the game.

Cheers,
Roberto
Image Image Image
B
82
S
21
G
8
Posts: 163
Reputation: 11,516

Post » Mon Nov 18, 2013 12:39 pm

Ok, while not really "minimal", I reduced the game to the splash screen and a linked credits screen, enough to test this and the issue is still there:
i.e. the music should start with the layout and then proceed playing without interruptions between the two screens (without restarting every time we go back and forth). The latter part works as expected but the music is triggered only when we touch the screen anywhere and not when the splash screen layout starts.

@ludei: I'm sending you a link to download the capx right now.

Thanks and all best!
Roberto
Image Image Image
B
82
S
21
G
8
Posts: 163
Reputation: 11,516

Post » Thu Nov 28, 2013 7:30 am

Hi folks! I am having the same bug with my game. Any solutions? It started after the newest CocoonJS (iOS) update, before that all the sounds worked fine.
Image
B
98
S
36
G
17
Posts: 351
Reputation: 15,953

Post » Fri Nov 29, 2013 12:57 am

I just tried recompiling my game after the latest CocoonJS update but the bug is still there, unfortunately.
Image Image Image
B
82
S
21
G
8
Posts: 163
Reputation: 11,516

Post » Mon Dec 09, 2013 10:01 am

Hi! I have the same problem when I launch my game in iOS launcher. But I worked around this problem by putting all audios files from Music folder to Sounds folder under construct 2. And then my music plays without the need to touch the screen.
Providence University, lecturer.

Tatung University, lecturer.



Consultant per question: USD$15 / time

Consultant by month: USD$300 / month

Customized project: USD$2500 / capx
B
78
S
18
G
4
Posts: 197
Reputation: 7,828

Post » Mon Dec 09, 2013 8:47 pm

it's not funny(( such bad problems may affect the Construct2 and Ludei                   



of this problem for my game will end (((
B
4
Posts: 8
Reputation: 342

Post » Tue Dec 10, 2013 2:24 pm

[QUOTE=jomo] Hi! I have the same problem when I launch my game in iOS launcher. But I worked around this problem by putting all audios files from Music folder to Sounds folder under construct 2. And then my music plays without the need to touch the screen.[/QUOTE]

This seems to work for me as well! Off to make a new build now! Thanks!!
Image Image Image
B
82
S
21
G
8
Posts: 163
Reputation: 11,516

Next

Return to How do I....?

Who is online

Users browsing this forum: No registered users and 25 guests