Start/Stop Animations one after another?

Get help using Construct 2

Post » Tue Jul 09, 2013 11:40 pm

Hello Again,

I have another newb question about animations. I have 6 a animations. Each one has 2 frames. I'm trying to get them to start one after another. As usual, I've tried approaching this in a variety of ways. None have worked and all of the examples are too complex for what I am attempting to do.

I've tried stopping all animations when layout starts and then starting them one at a time. That doesn't work at all for me. I also tried several other approaches that didn't work.

Now, for the last 24 hours, I've been tediously putting in the various times in the animation editor's frame for each animation. That is slowly working, but it takes forever for me to put in a time and then run it to see if the animation will run properly after the other. There has to be a better way.

My idea is on the layout's opening screen --> start the first animation. Then when it stops, proceed to the next animation and so on.

I know this is probably ridiculously simple for most of you, but I'm struggling with it. Yes, I've read and reread the manual. I've looked at tutorials, but I'm not stumbling onto the answer.

I'd be happy for a push in the right direction. Just off no bridges, please.

TIA... -Rachel
B
6
S
1
Posts: 21
Reputation: 822

Post » Wed Jul 10, 2013 7:44 am

I believe there is a condition for Animation Finished. If not, just compare the frame and see if its the last frame.
B
44
S
13
G
7
Posts: 603
Reputation: 7,936

Post » Tue Mar 07, 2017 1:24 am

hi all.. i have same problem with animation. Tell my please you find the decision
B
4
Posts: 6
Reputation: 202

Post » Tue Mar 07, 2017 1:31 am

Use on animation finished.

On Sprite Animation "One" Finished: Set Sprite animation "Two"

Do that for each animation.

Or you could just put all the frames in on single animation since you want them to be played on after the other but if they have different time rates that may not work.
Banned User
B
21
S
6
G
57
Posts: 1,229
Reputation: 33,961

Post » Tue Mar 07, 2017 12:24 pm

I have made tutorial on this
Image
B
58
S
35
G
32
Posts: 566
Reputation: 24,439

Post » Tue Mar 14, 2017 11:09 am

Why is this thread not closing after a response was made?

Still shows open responses.
Banned User
B
21
S
6
G
57
Posts: 1,229
Reputation: 33,961


Return to How do I....?

Who is online

Users browsing this forum: alextro, thewisetree and 1 guest