Steam uploading problem with latest NW.js! [FIXED]

Discussion and feedback on Construct 2

Post » Sat Nov 28, 2015 12:35 am

I got a serious issue here with Steam:

Tonight i needed to update the game. The game runs on the newer NW.js 0.13 a7, which has a file "nw.dll", which is essential to run the game. It is a fairly big file, 66mb for the 32bit version, 87 for the 64bit one.

The problem is, whenever i upload the game on Steam, it doesn't show on the builds list, preventing me from updating the branch. I've tested and figured out is the nw.dll file that causes the issue, as if i remove it from the files list, it uploads everything normally.

I can't even revert back to the previous version of NW.js, as the new game update relies on the new NW.js.

Is there anything i can do? I'm missing a deadline here and dont want to disappoint the users!

UPDATE: fixed by removing all old builds before uploading the new one, as it makes a checksum and the old files probably corrupted it.
Last edited by Danwood on Sat Nov 28, 2015 4:29 am, edited 1 time in total.
B
62
S
22
G
4
Posts: 357
Reputation: 6,478

Post » Sat Nov 28, 2015 2:18 am

That's very strange. I just uploaded my builds with alpha 6 and 7 which works fine from Steam.

I suspect there may be a conflict with your current build on Steam, because Steam does a checksum for any changes and it patches those individual files and not everything. Perhaps look into how to disable that feature and just update all files?
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Sat Nov 28, 2015 2:44 am

I'll try that! Hope not to mess anything :S
B
62
S
22
G
4
Posts: 357
Reputation: 6,478

Post » Sat Nov 28, 2015 3:34 am

No way, can't find an option for it, maybe i should try removing all the current builds from the depot and try again?
B
62
S
22
G
4
Posts: 357
Reputation: 6,478

Post » Sat Nov 28, 2015 3:38 am

Shouldn't you wait til the next stable update of C2 to update your game?
FREEDOM: Diegesis - Out Now for Windows! http://freedom.quicksandgames.com
B
21
S
5
G
1
Posts: 83
Reputation: 1,793

Post » Sat Nov 28, 2015 4:05 am

Quicksand wrote:Shouldn't you wait til the next stable update of C2 to update your game?


It's not a C2 problem, and apparently not even NW. It's an issue with my Steam repository, and i thing i might have fixed it with my last attempt.
B
62
S
22
G
4
Posts: 357
Reputation: 6,478

Post » Sat Nov 28, 2015 4:18 am

Did it fix by removing all the build in the depot and starting fresh?
B
70
S
24
G
19
Posts: 1,757
Reputation: 17,614

Post » Sat Nov 28, 2015 4:28 am

Silverforce wrote:Did it fix by removing all the build in the depot and starting fresh?


Yes, lol 8-)
B
62
S
22
G
4
Posts: 357
Reputation: 6,478


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 2 guests