Still no sound on iOS 6.0 with R119, any help?

Discussion and feedback on Construct 2

Post » Thu Feb 14, 2013 2:44 pm

Hello All,

First I want to say that this is my first post here and my first langage is french so I apologise for anything wrong in my posts in advance.    

Construct 2 is really a good product, I appreciate the number of beta and stable release and the overall quality of the platform. The community is also looking awesome around here!

So, back to my topic, the R119 release is supposed to adress audio issues on iOS in HTML5 browser games, it still doesnt work for me.

I'm using a iPod Touch 4 AND a iPad 4, both with iOS 6.0, in Safari. Even the SpaceBlaster from Scirra is not giving me sounds every time.

I don't have any capx for now because firstly I want to ask if someone here have tested it in R119 for sounds on iOS and if they succeeded?

Also, I have a question for Ashley or anyone here that knows the answer, we need a "first touch" event for audio to work on iOS, does it have to be a specific "Touch Event" like "On Any Touch Start" or if any "touch Event" enable audio for the rest of the game?

For example, I have a dice game in wich when we touch a dice it randomly spawn another number with a "throwing dice" sound...it works on my iPad for the whole game 1 time out of 5 or 10 sometimes but when it work that's ok for the whole game (and the next one if I don't hit the reload/refresh button on Safari)...when it doest work there is no sound at all during all the game.

Thanks in advance for the help.

Audio working fine in iOS was one of my most anticipated thing to look forward to in a stable release so I can't wait to know! I can't wait to test 9-patch too, it seems great!
I made 2 games so far: www.ID-Games.net
B
9
S
2
Posts: 47
Reputation: 1,315

Post » Fri Feb 15, 2013 5:26 am

Audio on iOS works fine even on older ones. I've tried 117 and HTML5 works fine. What doesn't worked (on 117) was cached audio, I'll test 119 and hope it's better.
B
8
S
3
G
2
Posts: 49
Reputation: 1,938

Post » Fri Feb 15, 2013 5:28 am

Delete .ogg files and keep .m4a files, then upload again
B
96
S
25
G
20
Posts: 3,055
Reputation: 22,644

Post » Fri Feb 15, 2013 11:31 am

I also have the same issue. I use cocoonJS to export my game on iphone. It's also not working after I deleted the ogg file.
B
14
S
2
G
1
Posts: 94
Reputation: 2,089

Post » Fri Feb 15, 2013 5:22 pm

It works fine for me (using SpaceBlaster) with both the oggs and m4as in the project. Can anyone reproduce it not working in a new project?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,600

Post » Wed Feb 20, 2013 12:02 pm

lol, I've never been able to get sound working on my iPhone 4, 4s, 5 or my iPad mini. Works fin in Firefox though on the pc after I export and Chrome while testing...

Tried uploading wav's as instructed in the manual to no avail, tried deleting the ogg file but then the sound dissappears for the project. :(

Ashley, I can provide my capx if it would help.
B
5
Posts: 19
Reputation: 513

Post » Fri Mar 22, 2013 5:37 pm

@Brett: Did you try my trick? You must include ogg AND m4a files into your project...and remove the "m4a" lines in the offline.appcache file to hear the sounds on iPod/iPhones/iPad steadily, that's the only thing that work 100% of the times for me on iOS.
I made 2 games so far: www.ID-Games.net
B
9
S
2
Posts: 47
Reputation: 1,315

Post » Sat Jun 22, 2013 2:19 pm

I got the same problem when using cocoonjs to convert project to iOS as well. As it is an old topic and there are lots of solutions, can anybody tell me which one works at the moment?

Thanks in advance.
B
10
S
4
G
2
Posts: 36
Reputation: 2,207

Post » Sat Jun 22, 2013 11:21 pm

I teste all solutions, but nothing did not work... Cocoonjs problem, android and iOS browsers problems...
B
24
S
4
G
2
Posts: 318
Reputation: 2,446


Return to Construct 2 General

Who is online

Users browsing this forum: pablo7 and 8 guests