Strange error on returning to layout

Get help using Construct 2

Post » Mon May 04, 2015 1:49 am

I have a game where you go into a blackhole to be sent to a random layout.
However, right now, I only have it set to go to a specified layout, for testing purposes, but this doesn't work correctly.

Layout 1 has a bunch of objects placed on the layers.

On Layout 1, when I go into the blackhole,I go to a Menu Layout and choose a layout. If I choose a new layout such as Layout 2, it works fine. However, if I choose Layout 1, it gives me an error.

Upon extensive testing, I removed every object from the pre-laid layout, and once I removed every single object except the portals, only then did it stop giving me the error. I decided that perhaps "creating" the objects through the system on Start of Layout would be the way to go to avoid this error.


However, upon testing that idea, I tested it out by going through the portal and back to Layout 1, and it seems to give me that error again, usually around every 7 to 10 cycles.


Here is the log:
Debug4 is the test layout, and SPACETRAVEL is the "Menu" for selecting a layout to go to.

Code: Select all
Change layout signalled to Debug4
Go to layout: SPACETRAVEL
Change layout signalled to SPACETRAVEL
Go to layout: Debug4
Change layout signalled to Debug4
Go to layout: SPACETRAVEL
Change layout signalled to SPACETRAVEL
Go to layout: Debug4
Change layout signalled to Debug4
Go to layout: SPACETRAVEL
Change layout signalled to SPACETRAVEL
Go to layout: Debug4
Change layout signalled to Debug4

Assertion failure: Drawing instance on wrong layer


Stack trace:
Error
    at Error (native)
    at assert2 (http://localhost:50000/preview_prelude.js:16:10)
    at Layer.drawInstanceGL (http://localhost:50000/layout.js:2152:22)
    at Layer.drawGL (http://localhost:50000/layout.js:2091:9)
    at Layout.drawGL (http://localhost:50000/layout.js:637:7)
    at Runtime.drawGL (http://localhost:50000/preview.js:2531:23)
    at Runtime.tick (http://localhost:50000/preview.js:2070:10)
    at tickFunc (http://localhost:50000/preview.js:623:47)



Once I press okay on the error, the game has less FPS and some objects seem to be "stuck" and inactive.
Any ideas?
B
7
S
1
Posts: 39
Reputation: 511

Post » Mon May 04, 2015 4:06 am

After lots of hours, I found a thread with hints on how to work-around this frustrating issue.

changing-layout-will-create-objects-on-the-next-layout_t121214?start=10


The problem could have been easily avoided if given a "Remove object" as oppose to "Destroy object"
B
7
S
1
Posts: 39
Reputation: 511


Return to How do I....?

Who is online

Users browsing this forum: R0J0hound and 22 guests