Strange Issue when creating new level

Get help using Construct 2

Post » Sun Apr 12, 2015 12:59 pm

Hey there I've recently been trying to make a second level in my game basically having the same event sheet and some recurring assets , however upon trying to test it i keep running into this screen which does not allot me to play the level , but it works fine on the previous level and the coding has not been changed at all by myself.
the error message will be enclosed.

http://i.imgur.com/vry70iz.png?1
B
6
Posts: 51
Reputation: 375

Post » Sun Apr 12, 2015 1:06 pm

It seems like the value X or actually x, doesn't exist.
Not sure if this value is a variable or just the x-value for a certain object not present on your layout, but there is a reference to this value in your event sheet and the value can not be read by javascript.
I told my dentist I had trouble with my teeth and asked her to fix it without looking in my mouth..
B
54
S
16
G
8
Posts: 6,160
Reputation: 19,775

Post » Sun Apr 12, 2015 1:29 pm

Well i have tried copying all the assets over from the previous layer which did nothing , its not a variable , i assume its talking about the use of X velocity in the script since i'm using physics , thanks for your reply i appreciate it.
B
6
Posts: 51
Reputation: 375

Post » Sun Apr 12, 2015 5:40 pm

Can you post a capx of this?
B
68
S
17
G
65
Posts: 2,185
Reputation: 41,310

Post » Mon Apr 13, 2015 11:31 pm

B
6
Posts: 51
Reputation: 375

Post » Wed Apr 15, 2015 6:24 pm

OK , I've managed to fix the issue , for whatever reason the collision polygons on the level's platforms were causing the issue as they had for some reason just randomly assigned themselves in places that cause overlaps and this was causing the error.

thanks to all who helped.
B
6
Posts: 51
Reputation: 375


Return to How do I....?

Who is online

Users browsing this forum: bigcatrik, newt, thatserafimkid and 4 guests