Sudden slowdown in Chrome

Discussion and feedback on Construct 2

Post » Sun Dec 15, 2013 9:03 pm

A game I've been building has been running very smoothly in Chrome for the past 2 days.

All of a sudden the preview has started to be quite choppy with a low frame rate.

I ran in debug mode and it says that I'm getting over 45fps, but that's not what I'm seeing on screen.

Is this a Chrome problem, or a 'my programming' problem? I've got very few objects in the level and a couple of webgl effects applied to layers.
B
6
S
2
Posts: 89
Reputation: 682

Post » Sun Dec 15, 2013 9:15 pm

Hard to say without a capx to look at - it is very likely to be to do with something you've recently changed rather than a bug, but anything is possible. It could be anything from an unnecessary For loop slowing things down to the use of a WebGL effect if you're using an older computer. Try turning WebGL off and see if that fixes it (this is a problem I frequently encounter on my computer). I can't think of any other possible quick fixes unless you're willing to share a capx, though. Hope this helps.
A big fan of JavaScript.
B
76
S
20
G
76
Posts: 2,285
Reputation: 47,554

Post » Sun Dec 15, 2013 9:15 pm

What's it like in Firefox or I.E. ?

Have you kept earlier iterations of your project?

Also, Have you added any 'Addons' to Chrome recently? Try disabling addons and test.zenox982013-12-15 21:17:15
If your vision so exceeds your ability, then look to something closer.
Moderator
B
137
S
31
G
87
Posts: 5,554
Reputation: 60,452

Post » Sun Dec 15, 2013 9:34 pm

Thanks for the responses people.

I'm not using much webGl and my computer isn't that old, so I didn't think it was that.

As for add-ons in Chrome - no, no recent ones and none updated recently either from what I would see.

For, for posterity, funny thing is when I put the power cable back into my laptop, it all proceeded to speed along like before again! So the problem was running off the battery rather than the direct power. Strange. I just hope it doesn't turn up in the final game - Ludum Dare 28 here and I've only got 4 hours to go!

Thanks again for your time!
B
6
S
2
Posts: 89
Reputation: 682

Post » Mon Dec 16, 2013 2:25 am

that answers that. Laptops reduce the GPU power use down to %75 or so. If you want to remain at 100% your going to have to modify that setting.

Your going to have to google that. But I know the settings exist. My wifes latop would crash when the GPU ran at %95+ but fine at 95 and less. So i had to set the setting while plugged in to run at %95. No problems since then.

So hunt the setting down and you will be fine at Ludum dare.
B
92
S
18
G
9
Posts: 2,455
Reputation: 15,113

Post » Mon Dec 16, 2013 1:05 pm

Many laptops ship with dual GPUs: a really weak one with poor performance to use as little battery power as possible, and a more powerful battery-draining one for gaming and high performance. (Or in some cases, one GPU with two power modes, with the same effect.) Pulling out the power cable often switches to the low-power mode and starts using the weaker GPU or low-power mode. This is a normal result with laptops and isn't a bug.
Scirra Founder
B
402
S
238
G
89
Posts: 24,644
Reputation: 196,095


Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 9 guests