Support PhoneGap 2.9.0 to fix market:// URI issue?

Discussion and feedback on Construct 2

Post » Wed Jul 03, 2013 8:35 am

Hi, I've ran into an issue when I click on an advertisement on my Android app it results in the error "The Protocol isn't supported market://...". When I export my app to PhoneGap in Construct2 (132/136), and upload it to the PhoneGap cloud compiler, it mentions that the version of PhoneGap used (2.7.0) is not the latest build (2.9.0).

After some searching, I see that this was a known issue and fixed in PhoneGap 2.9.0:

http://community.phonegap.com/nitobi/topics/ads_banner_with_market_dont_work_on_every_build_versione

Can Construct2 be updated to use PhoneGap 2.9.0?

Thanks!
B
5
Posts: 3
Reputation: 331

Post » Wed Jul 03, 2013 1:08 pm

It should use whatever version of PhoneGap you tell it to. If you originally upload with PhoneGap 2.7, it will stay on PhoneGap 2.7 until you explicitly set the version to something else, IIRC.
Scirra Founder
B
383
S
225
G
86
Posts: 24,119
Reputation: 190,546

Post » Wed Jul 03, 2013 2:18 pm

Ashley,

Thanks, I was thinking that something inside Construct2 was tied to a specific PhoneGap version. I had to delete the app inside Adobe PhoneGap Build, and then re-upload it to change make it use PhoneGap 2.9.0 (wasn't able to change it from the dropdown). The in app ads work fine, and now go to the Play Store when touched.

Thanks again!


B
5
Posts: 3
Reputation: 331


Return to Construct 2 General

Who is online

Users browsing this forum: spartan05 and 8 guests