Suspicious mouse behavior

Bugs will be moved here once resolved.

Post » Thu Aug 25, 2011 9:33 pm

C2 r51.2; Windows XP SP3; FireFox 6.0; ATI Radeon HD 4870

I recall having posted already about this issue. Maybe the post disappeared in the "incident" that occured a few weeks ago (I recall Ash talking about a manipulation that ended in posts loss).

Anyway this capx was made in r50 and still doesn't work as intended.

On right click on "Case", a green little square is supposed to be spawned at the (clicked "Case")'s position. It does appear but disappears right away.

On left click on "Case", if no "obstacle" is under mouse cursor, an "obstacle" is supposed to be spawned. It is spawned, and stay visible. Nevertheless, clicking on a "case" where there is already an "obstacle" shouldn't spawn a new obstacle.
Still it does.

Is my use of the events incorrect or is there a trouble with the invert of the mouse object ?
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Thu Aug 25, 2011 10:37 pm

Ah, good find again: it turns out a negated 'mouse over object' condition actually went ahead and picked the objects the mouse was not overlapping. Because there's an offscreen object, it always picks that, and if objects are picked the event runs. That's obviously not how it should work, so now if you invert the condition it never picks anything, just returns true or false depending if the mouse is over one of the objects.

As for the disappearing object... that had me stumped for a bit... then I checked its animation frames ;)
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580

Post » Thu Aug 25, 2011 11:09 pm

[QUOTE=Ashley] As for the disappearing object... that had me stumped for a bit... then I checked its animation frames ;)[/QUOTE]

Silly me
I totally forgot about that anim

Glad to support your support of C2 ^^
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Moderator
B
247
S
85
G
40
Posts: 7,000
Reputation: 57,795

Post » Sun Aug 28, 2011 1:29 am

Hey, can you verify this is fixed in r52?
Scirra Founder
B
359
S
214
G
72
Posts: 22,952
Reputation: 178,580


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 1 guest