System save / load only working in preview

Bugs will be moved here once resolved.

Post » Thu Jan 19, 2017 9:25 pm

Problem Description
The system save and load function work in the C2 preview mode (nw.js) but does not work after exporting to nw.js

Attach a Capx
https://www.dropbox.com/s/r044qtsd6547p ... .capx?dl=0

Description of Capx
Press the space bar to simulate going to the next level, then save and load the game.

Steps to Reproduce Bug
Run in nw.js preview mode. Press the space bar a few times to simulate going to the next level. Press save. Close the game, reopen and press load. The game will save and load as expected.

Export the project to nw.js. Press the space bar a few times to simulate going to the next level. Press save. Close the game, reopen and press load. The game save will not work. (I tested both win32 and win64 versions with the same result.)

Observed Result
Game does not save after exporting to nw.js

Expected Result
The game should save and load after export the same way it does in the C2 nw.js preview.

Affected Browsers
nw.js

Operating System and Service Pack
Windows 10.014393 Build 14393

Construct 2 Version ID
r241
B
61
S
20
G
56
Posts: 1,077
Reputation: 35,991

Post » Fri Jan 20, 2017 2:41 pm

Works just fine here with the latest NW.js 0.19.2.

Note preview and export use separate storage, so if you save in preview and then load after export, there isn't anything to load. You have to save with the exported version first.
Scirra Founder
B
399
S
236
G
89
Posts: 24,535
Reputation: 195,412

Post » Fri Jan 20, 2017 11:14 pm

Yes, I understand that preview and export use separate storage so that's not the issue. I am using an older version of nw.js because it was causing other issues with other games when I updated last time, so I rolled back. Maybe that has something to do with it. I will see if I can update to the latest version on another computer and test it there. Thank you for your help.
B
61
S
20
G
56
Posts: 1,077
Reputation: 35,991

Post » Sun Jan 22, 2017 10:31 pm

I just wanted to confirm that after upgrading to the latest NW.JS version the system save works as intended. The issue persists in the older version. Thanks again.
B
61
S
20
G
56
Posts: 1,077
Reputation: 35,991


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 4 guests