Tagged audio files occasionally pause upon completion

Bugs will be moved here once resolved.

Post » Sun May 10, 2015 3:02 am

I initially posted this under the "How do I" forum, but now that I can reproduce the bug it's probably better suited here.

Problem Description
In Chrome (latest version), when a looped music file is playing, other non-looping, tagged audio files occasionally pause upon finishing, rather than fully stopping like they should.

Attach a Capx
https://www.dropbox.com/s/4uvx5dh58x2u4 ... .capx?dl=0

Description of Capx
The file plays a looped music audio file on start-up. Then, every tick, it checks if a tag is not being used, and then attempts to play a sound file with that particular tag.

Steps to Reproduce Bug
  • Run in Chrome.
  • Hear beeping over piano music.
  • After a few seconds (can be anywhere from 1 to 30), the beeping stops.

Observed Result
The tagged audio sound file stops after a few seconds. Checking the audio debug menu at this point shows that the audio has paused at its last millisecond, and has not fully stopped; the tag has not been freed.

Expected Result
The tag ought to free up every time the sound file finishes, and as such the beeps ought to keep playing indefinitely.

Affected Browsers
  • Chrome: (YES)
  • FireFox: (NO)
  • Internet Explorer: (?)

Operating System and Service Pack
Windows 8.1.

Construct 2 Version ID
204.2 (Also tested in 192)
B
20
S
6
Posts: 29
Reputation: 2,160

Post » Thu May 14, 2015 2:31 pm

I can't reproduce, it seems to keep playing indefinitely just fine here in Chrome. Perhaps try it in Chrome Canary in case it's a Chrome bug that has already been fixed?
Scirra Founder
B
398
S
236
G
88
Posts: 24,433
Reputation: 194,635

Post » Mon May 18, 2015 3:34 pm

I've been having something like that happen recently too.

I have SFX say they are still playing but never release (see screenshot). "Repulse" is stuck (tagged) and both "land" and "boostcharge" are stuck even though they are not tagged.

Image
B
31
S
7
G
1
Posts: 80
Reputation: 2,550


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 2 guests