Test Request

Discussion and feedback on Construct 2

Post » Sun Dec 18, 2011 9:14 am

Hi All,

Could you test my game to see if the SHIFT & ARROW Keys are working
ok.

It might be my keyboard, when I try to move right and jump at the
same time, sometimes it works, and other times the SHIFT Key does
not jump the Player at all.

This used to work well on early upgrades of Construct 2.

Cheers

Works with Chrome 16 & XP Best.

http://www.hotkey.net.au/~foremost/index.htmlozziedave2011-12-18 09:15:30
B
4
S
1
G
2
Posts: 45
Reputation: 1,365

Post » Sun Dec 18, 2011 9:23 am

the same problem here
B
12
S
3
G
5
Posts: 174
Reputation: 4,018

Post » Sun Dec 18, 2011 10:32 am

There seem to be trouble with jumping while moving left and jumping while moving right. It doesn't seem to be random though.
B
73
S
20
G
10
Posts: 524
Reputation: 9,896

Post » Tue Dec 20, 2011 3:51 am

Thanks Folks,

Seems that I will have to research a better way for my player
to move around on a platform.
B
4
S
1
G
2
Posts: 45
Reputation: 1,365

Post » Tue Dec 20, 2011 4:28 am

That's a known problem in JS input. Hope it gets fixed soon. It wasn't made for games in the first place... :(
B
58
S
13
G
10
Posts: 632
Reputation: 12,505

Post » Tue Dec 20, 2011 4:35 am

[QUOTE=Kiyoshi] That's a known problem in JS input. Hope it gets fixed soon. It wasn't made for games in the first place... :([/QUOTE]

Seriously? If it was made for games then why... ..
B
47
S
10
G
6
Posts: 455
Reputation: 8,326

Post » Wed Dec 21, 2011 10:10 pm

[QUOTE=VampyricalCurse] [QUOTE=Kiyoshi] That's a known problem in JS input. Hope it gets fixed soon. It wasn't made for games in the first place... :([/QUOTE]

Seriously? If it was made for games then why... ..[/QUOTE]

What did you mean ? JS input right now is not robust enough to handle game with heavy input, lots of clicks and presses and stuff. I would know since my game is like this.
B
58
S
13
G
10
Posts: 632
Reputation: 12,505

Post » Wed Dec 21, 2011 10:52 pm

surely it should handle a simple left or right while pressing shift, this is something else, are you sure youre not limiting the jump? it could be that you are disabling the jump action in some events. have you looked into this?
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Post » Thu Dec 22, 2011 12:35 am

I believe Kiyoshi may be correct, at first I had a "GLOBAL EVENT SHEET"
which incorporated my keystrokes, which was included in my first Level
event sheet.

After the bad performance of the SHIFT KEY, I actually placed the Keystroke routines in the first level event sheet. That improved
the SHIFT KEY response slightly.

The more actions that you have happening on screen the more it
slows the action of keys for sure.

Tried changing things around but still no SHIFT response on every
second or third keystroke.

As the PLATFORM Object has this built in response, maybe this needs
to be looked at ?.

Cheers
B
4
S
1
G
2
Posts: 45
Reputation: 1,365

Post » Thu Dec 22, 2011 1:14 am

have you tried having a new sprite with the platform behavior, no settings changed and see if that behaves differently?
ImageImage
B
61
S
19
G
6
Posts: 809
Reputation: 9,028

Next

Return to Construct 2 General

Who is online

Users browsing this forum: No registered users and 15 guests