"The application was unable to start correctly"

Bugs will be moved here once resolved.

Post » Sat Oct 01, 2011 8:26 am

Hi all

I have a first-hurdle problem. When I try to run Construct 2 I get an error as follows:

Construct2.exe - Application Error
The application was unable to start correctly (0xc000007b). Click OK to close the application.

Not too informative!

Searched and couldn't find a similar Forum post on this.

The "0xc000007b" code googles to various possibilities: bad or missing dependency dlls, problems with .NET, threads of graphic drivers and all sorts. I can't find a definitive explanation as to what this error code really means.

Given the emphasis on .NET in some of the support topics out there for other software, I should say I do have .NET through to version 4 installed including 64bit. I'm on Windows 7 on a relatively fresh install/new laptop. But it does have Silverlight and MS Visual Studio 2010 Express installed.

Wondering if there is any help to be had here, because I haven't been able to try Construct 2 yet and I won't start wading through all the possible .dll problems or uninstalling other software without a bit more of a pointer>
Posts: 1
Reputation: 452

Post » Sat Oct 01, 2011 8:39 am

That's odd - Construct 2 doesn't use .NET and uses very few DLLs (mainly the HTML5 exporter DLL in the install directory).

Have you tried reinstalling C2?

Edit: you might want to try clearing your cache and re-downloading from Scirra.com - some other threads I've found indicate that error might be from corrupt files.Ashley2011-10-01 08:43:08
Scirra Founder
Posts: 22,830
Reputation: 176,686

Post » Sat Oct 15, 2011 3:20 pm

I downloaded construct2_62 and installed.
However, when I started it, it showed

"Construct2 (free edition test build) - Start page: Construct2.exe - The Application error"
"0x00448f47" by reference of address "0x00000004". It can't be "read"
Press OK to stop the application
Press cancel to debug

I clear by cache and tried to reinstall the setup file, but the result is the same. I tried 61, 60, 59, .... only 53 is OK.
My system is XP, SP3, IE8

What might be the problem? I tried many days.
And How can I solve this problem?

Thanks in advance.

Best wishes!

Posts: 5
Reputation: 485

Post » Sat Oct 15, 2011 6:50 pm

@tjh0504: Please report this as a new topic in the section "Bugs", not "Closed Bugs" please.
New to Construct ? Where to start

Image Image
Image Image

Please attach a capx to any help request or bug report !
Posts: 6,936
Reputation: 56,906

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests