The edges don't work.

Get help using Construct 2

Post » Mon Jan 06, 2014 11:43 pm

Hi guys, I am experiencing construct2 these days, I am following the tutorials but there's one thing I can not do the edges.
Look my game the first bird crosses the edge, something wrong?

my capx: db.tt/f0K4dvt7

I also have another small problem in the animation of the player.
Thank you in advancePlaoo2014-01-06 23:45:46
B
15
S
2
G
1
Posts: 17
Reputation: 1,015

Post » Tue Jan 07, 2014 12:02 am

You'll have to be more specific about the bird. I don't see a problem.

You need to add 'On landed': 'stand'.
ImageImageImage
B
71
S
21
G
220
Posts: 3,648
Reputation: 123,725

Post » Tue Jan 07, 2014 12:29 am

Thanks for the reply, the bird crossed the edge (UID 153, the white sprite on the left) I used the same system that is present in the tutorial. If bird collide with edge change direction, but does not work sometimes.
B
15
S
2
G
1
Posts: 17
Reputation: 1,015

Post » Tue Jan 07, 2014 1:07 am

I think the problem is that the bird isn't moving far enough away from the edge, so it hits the "on collision" event again and immediately flips back. I added this to 'left': bird_enemy: Set X to self.X+5, and 'right': bird_enemy: Set X to self.X-5. This works better. Experiment with that.
ImageImageImage
B
71
S
21
G
220
Posts: 3,648
Reputation: 123,725

Post » Tue Jan 07, 2014 6:53 pm

Like this?
https://db.tt/chhFo9qH
I still have problems, now the enemy moves in the Y axisPlaoo2014-01-07 18:54:34
B
15
S
2
G
1
Posts: 17
Reputation: 1,015

Post » Tue Jan 07, 2014 6:57 pm

No, on the collision switch.
ImageImageImage
B
71
S
21
G
220
Posts: 3,648
Reputation: 123,725

Post » Tue Jan 07, 2014 7:37 pm

Thanks for helping me, now the problem is the animation "stand". On even landed":"stand" works. Could you be more specific?
B
15
S
2
G
1
Posts: 17
Reputation: 1,015

Post » Tue Jan 07, 2014 7:54 pm

Duplicate what you have for On stopped, and change it to On landed, so both will switch to the 'stand' animation.
ImageImageImage
B
71
S
21
G
220
Posts: 3,648
Reputation: 123,725

Post » Tue Jan 07, 2014 8:10 pm

I asked you to be more specific because I already try this

https://db.tt/Yc5rndn6
B
15
S
2
G
1
Posts: 17
Reputation: 1,015

Post » Tue Jan 07, 2014 8:25 pm

It works for me. Maybe I'm not understanding the problem. Exactly what is the issue?
ImageImageImage
B
71
S
21
G
220
Posts: 3,648
Reputation: 123,725

Next

Return to How do I....?

Who is online

Users browsing this forum: MadSpy and 6 guests