For questions about using Classic.

Post » Sun Jul 20, 2008 9:57 pm

He got me again, but not as hard this time. Her's my story.

I was moving some sprites around, trying to find if i accidentaly had some duplicates on top of each other, when suddenly when i was dragging an object i got a strange error message saying that "an unknown error occured when accessing *path to my .cap*. I klicked ok, and everything worked as it should again. I ran the app and it worked. then i switched to the event list editor to try to fix a bug in my game. While i was looking at the evends WITHOUT TOUCHING ANYTHING i got the same message again. i klicked ok and everything was ok. then i tried to save the .app and got the "serious saving error" message. I thought it had corrupt my .cap as so many times before and i tried to open the latest backup. "An unknown error occured while accessing an unnamed file". I tried with the next backup and it didn't work either. It turns out that my latest six backups where corrupt. I restarted from my latest working backup. Everything worked but the "and unknown error" kept popping up without me doing anything. I talked on msn for a while and when i returned i got 3 of them. I closed the program, and it worked again.

When i was about to upload a file to this topic and looked through the latest backup i found that one of the files gave me an other error message. I had three "unnamed file" .caps, and then one " *path to my .cap* was not found" and then two more "unnamed file". I'm sending all of the corrupt .caps to you ashley.

Could this be the same thing that happened a while back when all my 50 backups of my game was ruined? That time it destroyed versions that i had been using before and that i knew should work.This time it might have been that it just saved the same error to five backups.

Edit: Now when i was looking through the files again to try to find what files was corrupt one of them suddenly said: There is not enough video memory to open this frame editor. Please close some other editors and try again.

I've lost the orientation. you'll get a bunch of like 7-8 diferent corrupt files.
Posts: 744
Reputation: 3,288

Post » Sun Jul 20, 2008 10:04 pm

What happens with this kind of bug is something goes wrong in Construct and every time you hit save it's generating a corrupt file. I'll take a look at the caps you sent and see if I can find anything wrong...
Scirra Founder
Posts: 22,822
Reputation: 176,618

Return to Help & Support using Construct Classic

Who is online

Users browsing this forum: No registered users and 4 guests