Ah I see, so
Set position of head to 'player'
Set angle of head to 'player'
Set width of head to 'player'
Set height of head to 'player'
In all those cases, the word 'player' would become:
Thats actually a pretty cool idea, however, some plugins do overload their names, so using 'TextBox' infact means 'TextBox.text'
Still, thats a pretty interesting idea anyways. Perhaps an action such as 'width' can have some kind of declaration to describe to other plugins which expression they should attempt to use...eg:
for the action 'setWidth', if other object has a '.width' expression, use that when you type 'Sprite'