Tile Map Edit Bug

Bugs will be moved here once resolved.

Post » Thu Nov 14, 2013 8:18 am

Capx is not needed for producing this error.

Steps to reproduce:
1. Create new project.
2. Add tilemap object.
3. Choose recommended settings for tilemap object.
4. Pick any tile form tilemap window.
5. Try to place tile on tilemap object.

Observed result:
Sometimes, when you click on a tilemap it selects tilemap object itself.

Expected result:
Must place selected tile on tilemap object.

Browsers affected:
Chrome: no
Firefox: no
Internet Explorer: no

Editor Only!

Operating system & service pack:
Windows 7 x64 latest updates
Windows 8.1 x64 latest updates

Construct 2 version:
r150
    
B
11
S
2
G
1
Posts: 25
Reputation: 1,685

Post » Thu Nov 14, 2013 9:33 am

Have got the Tilemap properties window set to 'Auto hide' ? That's the only way I can reproduce this issue.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,416
Reputation: 59,518

Post » Thu Nov 14, 2013 12:38 pm

[QUOTE=zenox98] Have got the Tilemap properties window set to 'Auto hide' ? That's the only way I can reproduce this issue.[/QUOTE]

Yes! You are right! But it still seams not like a correct behavior.
B
11
S
2
G
1
Posts: 25
Reputation: 1,685

Post » Thu Nov 14, 2013 1:05 pm

It kind of seems logical to me. The focus is no longer on the Tilemap Property window, so reverts back to Object mode.

If the Tilemap Property window is open, then it has focus, and it works as expected.

Ashley will clarify when he has a chance, I'm sure.
If your vision so exceeds your ability, then look to something closer.
Moderator
B
134
S
30
G
86
Posts: 5,416
Reputation: 59,518

Post » Fri Nov 15, 2013 5:18 pm

Yeah, looks like it would be useful if it still worked when the bar is auto-hidden. Should be fixed in the next build.
Scirra Founder
B
398
S
236
G
88
Posts: 24,428
Reputation: 194,600


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests