Tile object + jumpthru behaviour set invisible

Bugs will be moved here once resolved.

Post » Sat Jan 18, 2014 8:11 am

Link to .capx file (required! If link is blocked remove the http and www parts):
members.tele2.nl/yorokobi/Bug_Tile_Jumpthru_Invisible_not_working.capx

Steps to reproduce:
1. Tile + jumpthru behaviour set as visible is created. Place on the left side.
2. Duplicate Tile + jumpthru behaviour but this time set as invisible. Place on the right side.
3. Now simply drop an object to both tiles, and the invisible let the object go thru which shouldn't allow.

Observed result:
Collision on invisible not working I guess

Expected result:
Invisible is the same as visible, only visually invisible. Previous version of Construct 2 worked correctly.

Browsers affected:
Chrome: yes
Firefox: yes
Internet Explorer: yes

Operating system & service pack:
Windows 7 & SP1

Construct 2 version:
    R158Kwun Yu Ho2014-01-18 08:13:19
B
11
S
1
Posts: 16
Reputation: 609

Post » Sun Jan 19, 2014 1:42 am

I tested this Capx on R158.2 , with FFox and Chrome and this indeed seem to happen.
Need help? Upload .capx file with your question.
B
16
S
4
G
2
Posts: 233
Reputation: 2,560

Post » Mon Jan 20, 2014 3:11 am

Yes, I just found the very same problem in my latest platform game where now the character can't jump anymore on the various platforms and simply goes through them like if they were not in place!
This was working perfectly fine earlier but I also updated all my browsers recently so I'm not sure if the issue originates from C2 or from a browser...

In any case, I experimented a bit and found a workaround: set your platform to "visible" but change its opacity to 0 (so that it becomes invisible again): this will make it behave properly again.
Image Image Image
B
82
S
21
G
8
Posts: 163
Reputation: 11,516

Post » Mon Jan 20, 2014 6:31 pm

That's a good alternative solution, thnx! But still, this isn't right, so it need to be fixed in the next revision of C2.
B
11
S
1
Posts: 16
Reputation: 609

Post » Mon Jan 20, 2014 10:54 pm

I agree. Even though I have not taken any measurements, I'd expect the sprite/tile with Opacity=0 to cause slightly more menory/gpu/cpu load than using entirely invisible object.
Need help? Upload .capx file with your question.
B
16
S
4
G
2
Posts: 233
Reputation: 2,560

Post » Tue Jan 21, 2014 5:29 am

I agree, that's just a workaround for the time being ;)
Image Image Image
B
82
S
21
G
8
Posts: 163
Reputation: 11,516

Post » Tue Jan 21, 2014 7:52 pm

After upgrading to 158.2 from previous stable version, most jump-thru's stopped working correctly in my platformer. I replaced just one of them with another copy that still worked (by holding cntl and dragging the new jump-thru sprite into place) and all on that layout started working correctly again. I had to repeat this for every level.

Tested this also on the included capx for this post and by making a copy of the invisible sprite, it worked as expected.TheBogueRat2014-01-21 19:56:08
B
17
S
4
Posts: 31
Reputation: 1,600

Post » Wed Jan 22, 2014 1:17 am

Eyyy your right, thnx! Just like you I have to do it for all the levels. Guess I have to... Hopefully this problem wil not repeat again in the next revision, otherwise we have to do it all over again.

Another question about Tiles. Maybe you guys know anything about it?

I have made a very long tile-object (as background). When going from left to right (with my playable object) the farther I go the more pixelate the tile-object shows. It only happens when "Enable WebGL" is set "Off". If "On" then no problem, but I don't use WebGL because Ludei advice me not to use it. Because it's very unstable right now, which will let mobile games crash.

Does anyone has the same problem? I'm not sure if this is a bug or a just a C2 software limitation. Maybe someone with a solution?Kwun Yu Ho2014-01-22 01:23:15
B
11
S
1
Posts: 16
Reputation: 609

Post » Fri Jan 24, 2014 5:52 pm

Thanks, should be fixed in the next build.
Scirra Founder
B
387
S
230
G
88
Posts: 24,251
Reputation: 192,464

Post » Tue Jan 28, 2014 7:54 pm

love how quick you'll fix things!
B
15
S
3
Posts: 22
Reputation: 1,802

Next

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests