Tile problem after Exporting.

Discussion and feedback on Construct 2

Post » Sat Jan 24, 2015 11:46 pm

Hi Guys, I recently exported a few level prototype to my game to a temporary website so I could have a couple friends try it out. While playing through construct 2. The tiles seem tight with no gaps. But after exporting and opening the link from a browser. All my ground tiles have a small space. So it looks like you can still see a grid. I have checked in construct 2 and everything is tight and touching. Anyone know what would cause this?
B
7
S
1
Posts: 42
Reputation: 461

Post » Sun Jan 25, 2015 12:21 am

Are you using a tilemap? If so, then the problem is most likely the scaling of the game to the canvas. Is "Seamless mode" set to "On" in the tilemap's properties?
B
19
S
3
G
1
Posts: 29
Reputation: 1,038

Post » Sun Jan 25, 2015 1:27 am

I am not using a tile map The ground is built out of sprites that i have made. and sized to 128 x 128
You do not have the required permissions to view the files attached to this post.
B
7
S
1
Posts: 42
Reputation: 461

Post » Sun Jan 25, 2015 1:30 am

This is how it looks as I run it from Construct 2 before exporting.
You do not have the required permissions to view the files attached to this post.
B
7
S
1
Posts: 42
Reputation: 461

Post » Sun Jan 25, 2015 3:36 am

Looks like the float point rendering issue. Try changing your settings to letterbox integer scale, point sampling, and pixel rounding. Or you could put a 1 px overlap in the sprites.

Honestly, in your situation, you should probably be using tilemap rather then sprites though.
B
61
S
20
G
56
Posts: 1,077
Reputation: 35,986


Return to Construct 2 General

Who is online

Users browsing this forum: disneycom2, kazdalugur and 7 guests