Tiled background glitch

Bugs will be moved here once resolved.

Post » Thu Apr 19, 2012 4:54 pm

yeah I noticed this too in my first project. I found out the only way to get rid of it was point sampling or adding transparent pixels like mentioned above. That was in r85
B
13
S
5
G
2
Posts: 306
Reputation: 3,262

Post » Thu Jul 05, 2012 9:02 pm

anymore information about this issue because I've been having the same problem as well but I want my project to set to linear sampling since I have hand drawn sprites.

And what is the method of adding transparent pixels?
Image
B
57
S
14
G
6
Posts: 493
Reputation: 11,253

Post » Thu Jul 05, 2012 9:57 pm

Hmmm I'm not sure if @Ashley had a deeper look into this.

Adding a transparent pixel only works if you are using tiled backgrounds that repeat on one axis. Just go to the image editor and resize it by one pixel (without stretching).
B
106
S
40
G
10
Posts: 456
Reputation: 13,152

Post » Fri Jul 06, 2012 2:13 pm

I don't believe this is a bug - I think people usually are getting confused by sub-pixel positioning and non-power-of-two textures. You can still use linear sampling and avoid tiled background seaming by enabling 'pixel rounding' in project properties.

So I'm actually going to close this report, especially since I can no longer find any of the repro .capx's or the links are dead (part of the reason I recommend Dropbox). If you have a Tiled Background which isn't tiling properly, and the Point sampling or Pixel Rounding project properties don't seem to help, please reproduce the project in a minimal new project and post a new bug report (and host the file on Dropbox!).
Scirra Founder
B
357
S
214
G
72
Posts: 22,946
Reputation: 178,228

Previous

Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 0 guests