Tiled background image doesn't display

Bugs will be moved here once resolved.

Post » Tue Sep 30, 2014 1:45 pm

Problem Description
Tiled background images do not display. I tried creating the Ghost Shooter tutorial and quickly ran into a problem where I could not display the tutorial background.

I've seen the post where you are blaming this kind of problem on the display driver. However, I actually tried 2 different graphics cards on the same system and had exactly the same problem. The problem happened with an A6-7400k (Radeon R5) AND an NVIDA Quadro 2000, both with the latest drivers available. Because the problem manifests itself in exactly the same way (i.e drawing tiled backgrounds) on two different graphics cards I find it hard to believe it is the display driver.

I've attached the output from dxdiag showing my system information.

Steps to Reproduce Bug
    Insert new object
    Choose tiled background
    Select image
    Image does not display in image editor unless I force a redraw of the window (.e.g. resize the window)
    After closing the image editor, the tiled image does not display

Observed Result
Unable to display tiled background.

Expected Result
Display tiled background. This works fine on other machines.


Operating System and Service Pack
Windows 7 x64, sp1

Construct 2 Version ID
Release 178 (64 bit)
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 3
Reputation: 181

Post » Tue Sep 30, 2014 1:53 pm

@candersrf we can't exactly see what is wrong without that capx now can we :D
B
12
S
3
G
1
Posts: 109
Reputation: 1,979

Post » Wed Oct 01, 2014 12:08 pm

Can't reproduce, works fine here. If this really was a C2 bug I'm sure we'd be inundated with reports since it involves such a common feature, but this is the only report we have so far. Graphics drivers are such a disaster (see our blog archives) that it would not surprise me at all if both systems you tried had buggy drivers. Given that I assume it's working correctly for the vast majority of our users, I would say our code is correct. Not sure what we can do about this, we could work for days and not find a workaround.
Scirra Founder
B
397
S
236
G
88
Posts: 24,427
Reputation: 194,568

Post » Sat Oct 04, 2014 3:53 pm

Well, obviously it is a problem. I doubt you could blame this on the graphics driver since it happens with 2 -different graphics cards from 2 vendors (AMD and Nvidia). I've attached the capx file per the comment. I will not be using your product because of this bug.
You do not have the required permissions to view the files attached to this post.
B
3
Posts: 3
Reputation: 181

Post » Sat Oct 04, 2014 7:05 pm

In your capx. There's nothing there. The TiledBG is empty. That's why you can't see it. Draw in a BG and it works fine.
B
86
S
43
G
71
Posts: 601
Reputation: 43,619

Post » Sat Oct 04, 2014 8:14 pm

Ok, well I found out more about the bug,including how to work around it. So I think we can safely say it's not a driver issue. Here are the steps to reproduce the bug and to workaround the issue:

Select "Insert New Object"
Choose "Tiled Background" from the "Insert New Object" dialog
Select a location for the TiledBG
-- the Edit Image dialog is displayed --
I attempt to load an image from an existing file (i.e. click on the folder icon)
Bug : The image is not displayed on in the Edit Image dialog AND if I close the window an empty background frame is displayed in the layout
Workaround : However, if I choose the "pencil" icon and click anywhere on the window the image that I had attempted to load from a file magically displays AND when I close the window it shows in the layout. It's as if the dialog had an issue loading/rendering the image but when the pencil tool was used it was able to render the image AND mark the background as being changed (i.e. set a dirty flag). If I don't click on the screen with the pencil tool enabled the image is not displayed when I close the Edit Image dialog and return to the layout view.
B
3
Posts: 3
Reputation: 181


Return to Closed bugs

Who is online

Users browsing this forum: No registered users and 3 guests