Tiled Backgrounds & Normal Maps

Get help using Construct 2

Post » Tue Sep 24, 2013 12:54 am

I've tried searching for this, but nothing has come up.

Please see the attached:

CAPX

In the CAPX I have a tiled background with a normal map on the left, and a standard sprite on the right.

I can't seem to get normal maps working as expected on tiled backgrounds. It all appears to be inverted. If you have a look at the code, the tiled and the sprite code is the same, however they respond differently.

Also, I noticed that when I scaled the tiled background, in the editor it appears to shrink down and look odd, however at runtime it looks fine. It's just the inversion that is really the problem.

I've tried looking it up. Are tiled backgrounds just incompatible with normal maps?

I can work just fine with sprites, but figured it would be better to use a more memory efficient tiled background.

Hope I've made sense!
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 963
Reputation: 10,721

Post » Tue Sep 24, 2013 1:05 am

Just read a bit of the manual, and it says that rather than applying effects to multiple objects, I should apply it to a layer.

Any suggestions on how I should apply normalmaps to a layer?

I've tried:

((Mouse.X-scrollx)/LayoutWidth)*100
((Mouse.Y-scrolly)/LayoutHeight)*100

But as expected, it did not work :(
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 963
Reputation: 10,721

Post » Tue Sep 24, 2013 1:08 am

can works if you put -512 for the height of your tiledbackground with bumpmaping
B
38
S
13
G
4
Posts: 152
Reputation: 5,142

Post » Tue Sep 24, 2013 1:13 am

As far as I can tell, that won't help me if I plan on making the tiles any larger. Also, it's now upside down.

Have I misunderstood. You mean to actually change the Y scale of the object to -512 in the layout editor?
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 963
Reputation: 10,721

Post » Tue Sep 24, 2013 1:20 am

NormalMapTest.capxanata2013-09-24 01:26:00
B
38
S
13
G
4
Posts: 152
Reputation: 5,142

Post » Tue Sep 24, 2013 1:24 am

@anata Broken link:(
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 963
Reputation: 10,721

Post » Tue Sep 24, 2013 1:26 am

it's good now
B
38
S
13
G
4
Posts: 152
Reputation: 5,142

Post » Tue Sep 24, 2013 1:34 am

Thanks @anata,

but that can't be the solution. Is this a bug @Ashley?

Anata, in the version you sent me, if you drag select the tiled backgrounds, and then scale the right hand side so it's half the size it was previously, and then try it again, does it work for you? For me, the light no longer follows the mouse.
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 963
Reputation: 10,721

Post » Wed Sep 25, 2013 12:38 am

Does anyone have any wise words on how you apply and make use of a normal map on a layer?
@bearboxmedia
www.bearboxmedia.com

Nintendo Wii U Developer using Construct 2
B
79
S
12
G
7
Posts: 963
Reputation: 10,721

Post » Mon Feb 17, 2014 7:35 pm

ImageImageImageImage
B
157
S
66
G
41
Posts: 2,598
Reputation: 34,823

Next

Return to How do I....?

Who is online

Users browsing this forum: DharmaOne and 16 guests